# CVE-2015-5531: Improper Limitation of a Pathname to a Restricted Directory in Elasticsearch

> Remote attackers can read arbitrary files from the server via directory traversal in Elasticsearch snapshot API calls.

- **Severity:** Medium 5.0 (`AV:N/AC:L/Au:N/C:P/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Aug 2015
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-jjq8-vfjq-j6v4

## What is CVE-2015-5531?

CVE-2015-5531 is a medium-severity path traversal vulnerability in n/a, published on 17 Aug 2015. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Directory traversal vulnerability in Elasticsearch before 1.6.1 allows remote attackers to read arbitrary files via unspecified vectors related to snapshot API calls.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2015-5531?

2 open source packages ship an affected version, including org.elasticsearch:elasticsearch. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.elasticsearch:elasticsearch` | Maven | All versions | 1.6.1 |
| `org.elasticsearch:elasticsearch` | Maven | All versions | 1.6.1 |

Products: Elasticsearch Elasticsearch.

## How do I fix CVE-2015-5531?

Upgrade org.elasticsearch:elasticsearch to 1.6.1 or later.

## Is CVE-2015-5531 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2015-5531 exists.

Public exploit code:

- https://github.com/MoCh3n/CVE-2015-5531-POC (github_poc): https://github.com/MoCh3n/CVE-2015-5531-POC
- ElasticSearch 1.6.0 - Arbitrary File Download (exploitdb)
- https://github.com/xpgdgit/CVE-2015-5531 (github_poc): https://github.com/xpgdgit/CVE-2015-5531
- ElasticSearch Snapshot API Directory Traversal (metasploit)
- ElasticSearch <1.6.1 - Local File Inclusion (nuclei): http/cves/2015/CVE-2015-5531.yaml

## Other vulnerabilities in n/a

- [CVE-2015-4165](https://insights.sbomify.com/CVE-2015-4165/): Improper Access Control in Elasticsearch (high 7.5)
- [CVE-2015-3337](https://insights.sbomify.com/CVE-2015-3337/): Improper Limitation of a Pathname to a Restricted Directory in Elasticsearch (medium 4.3)
- [CVE-2014-6439](https://insights.sbomify.com/CVE-2014-6439/): Cross-site scripting in Elasticsearch (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2015-5531 and fix it if it is affected.

What it is: CVE-2015-5531 is a medium-severity path traversal vulnerability in n/a, published on 17 Aug 2015. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2015-5531 exists.

Affected packages and fixed versions:
- org.elasticsearch:elasticsearch (Maven): affected all versions; fixed in 1.6.1
- org.elasticsearch:elasticsearch (Maven): affected all versions; fixed in 1.6.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2015-5531/ (Markdown: https://insights.sbomify.com/CVE-2015-5531/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2015-5531
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2015-5531
- OSV: https://osv.dev/vulnerability/CVE-2015-5531

---
From sbomify Insights: https://insights.sbomify.com/CVE-2015-5531/
Summaries are generated and may contain mistakes; the official description above is the record.
