# CVE-2015-5654: Cross-Site Scripting in dojo

> Remote attackers can inject arbitrary web script or HTML into applications using the Dojo Toolkit library, potentially compromising user sessions.

- **Severity:** Medium 4.3 (`AV:N/AC:M/Au:N/C:N/I:P/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 11 Oct 2015
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-p82g-2xpp-m5r3

## What is CVE-2015-5654?

CVE-2015-5654 is a medium-severity cross-site scripting vulnerability in n/a, published on 11 Oct 2015. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Cross-site scripting (XSS) vulnerability in Dojo Toolkit before 1.2 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2015-5654?

2 open source packages ship an affected version, including dojo. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `dojo` | npm | All versions | 1.9.1 |
| `dojo` | npm | All versions | 1.9.1 |

Products: Dojotoolkit Dojo.

## How do I fix CVE-2015-5654?

Upgrade dojo to 1.9.1 or later.

## Is CVE-2015-5654 being exploited?

There is no known exploitation of CVE-2015-5654 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2010-2272](https://insights.sbomify.com/CVE-2010-2272/): Other in n/a (critical 10.0)
- [CVE-2010-2276](https://insights.sbomify.com/CVE-2010-2276/): Misconfiguration in n/a (critical 10.0)
- [CVE-2018-1000665](https://insights.sbomify.com/CVE-2018-1000665/): Improper Neutralization of Input During Web Page Generation in Dojo Dojo Objective Harness (medium 6.1)
- [CVE-2018-6561](https://insights.sbomify.com/CVE-2018-6561/): dijit editor cross-site scripting vulnerability (medium 6.1)
- [CVE-2010-2273](https://insights.sbomify.com/CVE-2010-2273/): Cross-Site Scripting in dojo (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2015-5654 and fix it if it is affected.

What it is: CVE-2015-5654 is a medium-severity cross-site scripting vulnerability in n/a, published on 11 Oct 2015. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2015-5654 in the wild and no public exploit code.

Affected packages and fixed versions:
- dojo (npm): affected all versions; fixed in 1.9.1
- dojo (npm): affected all versions; fixed in 1.9.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2015-5654/ (Markdown: https://insights.sbomify.com/CVE-2015-5654/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2015-5654
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2015-5654
- OSV: https://osv.dev/vulnerability/CVE-2015-5654

---
From sbomify Insights: https://insights.sbomify.com/CVE-2015-5654/
Summaries are generated and may contain mistakes; the official description above is the record.
