CVE-2015-5723 Doctrine Security Misconfiguration Vulnerability
Local attackers can execute arbitrary code and escalate privileges if the application uses a zero umask, due to world-writable cache directories in Doctrine libraries.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Local or same network only
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2015-5723?
CVE-2015-5723 is a high-severity vulnerability in Debian Debian Linux, published on 7 Jun 2016. It can only be exploited from the same machine or local network, with no action from the victim.
Official description
Doctrine Annotations before 1.2.7, Cache before 1.3.2 and 1.4.x before 1.4.2, Common before 2.4.3 and 2.5.x before 2.5.1, ORM before 2.4.8 or 2.5.x before 2.5.1, MongoDB ODM before 1.0.2, and MongoDB ODM Bundle before 3.0.1 use world-writable permissions for cache directories, which allows local users to execute arbitrary PHP code with additional privileges by leveraging an application with the umask set to 0 and that executes cache entries as code.
Weakness: CWE-264
Which versions are affected by CVE-2015-5723?
28 open source packages ship an affected version, including doctrine/cache, aws/aws-sdk-php and doctrine/annotations. It affects 10 products.
| Package | Affected | Fixed in |
|---|---|---|
doctrine/cache Packagist | From 1.0.0 | 1.3.2 |
doctrine/cache Packagist | From 1.0.0 | 1.3.2 |
doctrine/cache Packagist | From 1.4.0 | 1.4.2 |
doctrine/cache Packagist | From 1.4.0 | 1.4.2 |
aws/aws-sdk-php Packagist | From 3.0.0 | 3.2.1 |
aws/aws-sdk-php Packagist | From 3.0.0 | 3.2.1 |
22 more packages
doctrine/annotations Packagist | All versions | 1.2.7 |
doctrine/annotations Packagist | All versions | 1.2.7 |
doctrine/common Packagist | All versions | 2.4.3 |
doctrine/common Packagist | All versions | 2.4.3 |
doctrine/common Packagist | From 2.5.0-stable | 2.5.1 |
doctrine/common Packagist | From 2.5.0-stable | 2.5.1 |
doctrine/mongodb-odm Packagist | All versions | 1.0.2 |
doctrine/mongodb-odm Packagist | All versions | 1.0.2 |
doctrine/mongodb-odm-bundle Packagist | All versions | 3.0.1 |
doctrine/mongodb-odm-bundle Packagist | All versions | 3.0.1 |
doctrine/orm Packagist | From 2.5.0 | 2.5.1 |
doctrine/orm Packagist | From 2.5.0 | 2.5.1 |
zendframework/zend-cache Packagist | From 2.4.0 | 2.4.8 |
zendframework/zend-cache Packagist | From 2.4.0 | 2.4.8 |
zendframework/zend-cache Packagist | From 2.5.0 | 2.5.3 |
zendframework/zend-cache Packagist | From 2.5.0 | 2.5.3 |
zendframework/zendframework Packagist | From 2.4.0 | 2.4.8 |
zendframework/zendframework Packagist | From 2.4.0 | 2.4.8 |
zendframework/zendframework1 Packagist | From 1.12.0 | 1.12.16 |
zendframework/zendframework1 Packagist | From 1.12.0 | 1.12.16 |
zfcampus/zf-apigility-doctrine Packagist | From 1.0.0 | 1.0.3 |
zfcampus/zf-apigility-doctrine Packagist | From 1.0.0 | 1.0.3 |
Products include Debian Debian Linux, Doctrine-Project Annotations, Doctrine-Project Cache, Doctrine-Project Common, Doctrine-Project Doctrinemongodbbundle, Doctrine-Project Mongodb-Odm and 4 more.
How do I fix CVE-2015-5723?
Upgrade doctrine/cache to a fixed version for your release line: 1.3.2 or 1.4.2.
Is CVE-2015-5723 being exploited?
There is no known exploitation of CVE-2015-5723 in the wild and no public exploit code.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as CLSA-2026-1787221779, DEBIAN-CVE-2015-5723, GHSA-pw5c-xqf2-6xc2, MGASA-2015-0391.