# CVE-2015-5723: Doctrine Security Misconfiguration Vulnerability

> Local attackers can execute arbitrary code and escalate privileges if the application uses a zero umask, due to world-writable cache directories in Doctrine libraries.

- **Severity:** High 7.8 (`CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Jun 2016
- **Updated:** 6 Aug 2024
- **Also known as:** CLSA-2026-1787221779, DEBIAN-CVE-2015-5723, GHSA-pw5c-xqf2-6xc2, MGASA-2015-0391

## What is CVE-2015-5723?

CVE-2015-5723 is a high-severity vulnerability in Debian Debian Linux, published on 7 Jun 2016. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Doctrine Annotations before 1.2.7, Cache before 1.3.2 and 1.4.x before 1.4.2, Common before 2.4.3 and 2.5.x before 2.5.1, ORM before 2.4.8 or 2.5.x before 2.5.1, MongoDB ODM before 1.0.2, and MongoDB ODM Bundle before 3.0.1 use world-writable permissions for cache directories, which allows local users to execute arbitrary PHP code with additional privileges by leveraging an application with the umask set to 0 and that executes cache entries as code.

Weakness: CWE-264

## Which versions are affected by CVE-2015-5723?

28 open source packages ship an affected version, including doctrine/cache, aws/aws-sdk-php and doctrine/annotations. It affects 10 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `doctrine/cache` | Packagist | From 1.0.0 | 1.3.2 |
| `doctrine/cache` | Packagist | From 1.0.0 | 1.3.2 |
| `doctrine/cache` | Packagist | From 1.4.0 | 1.4.2 |
| `doctrine/cache` | Packagist | From 1.4.0 | 1.4.2 |
| `aws/aws-sdk-php` | Packagist | From 3.0.0 | 3.2.1 |
| `aws/aws-sdk-php` | Packagist | From 3.0.0 | 3.2.1 |
| `doctrine/annotations` | Packagist | All versions | 1.2.7 |
| `doctrine/annotations` | Packagist | All versions | 1.2.7 |
| `doctrine/common` | Packagist | All versions | 2.4.3 |
| `doctrine/common` | Packagist | All versions | 2.4.3 |
| `doctrine/common` | Packagist | From 2.5.0-stable | 2.5.1 |
| `doctrine/common` | Packagist | From 2.5.0-stable | 2.5.1 |
| `doctrine/mongodb-odm` | Packagist | All versions | 1.0.2 |
| `doctrine/mongodb-odm` | Packagist | All versions | 1.0.2 |
| `doctrine/mongodb-odm-bundle` | Packagist | All versions | 3.0.1 |
| `doctrine/mongodb-odm-bundle` | Packagist | All versions | 3.0.1 |
| `doctrine/orm` | Packagist | From 2.5.0 | 2.5.1 |
| `doctrine/orm` | Packagist | From 2.5.0 | 2.5.1 |
| `zendframework/zend-cache` | Packagist | From 2.4.0 | 2.4.8 |
| `zendframework/zend-cache` | Packagist | From 2.4.0 | 2.4.8 |
| `zendframework/zend-cache` | Packagist | From 2.5.0 | 2.5.3 |
| `zendframework/zend-cache` | Packagist | From 2.5.0 | 2.5.3 |
| `zendframework/zendframework` | Packagist | From 2.4.0 | 2.4.8 |
| `zendframework/zendframework` | Packagist | From 2.4.0 | 2.4.8 |
| `zendframework/zendframework1` | Packagist | From 1.12.0 | 1.12.16 |
| `zendframework/zendframework1` | Packagist | From 1.12.0 | 1.12.16 |
| `zfcampus/zf-apigility-doctrine` | Packagist | From 1.0.0 | 1.0.3 |
| `zfcampus/zf-apigility-doctrine` | Packagist | From 1.0.0 | 1.0.3 |

Products: Debian Debian Linux, Doctrine-Project Annotations, Doctrine-Project Cache, Doctrine-Project Common, Doctrine-Project Doctrinemongodbbundle, Doctrine-Project Mongodb-Odm, Doctrine-Project Object Relational Mapper, Zend Zend-Cache, Zend Zend Framework, Zend Zf-Apigility-Doctrine.

## How do I fix CVE-2015-5723?

Upgrade doctrine/cache to a fixed version for your release line: 1.3.2 or 1.4.2.

## Is CVE-2015-5723 being exploited?

There is no known exploitation of CVE-2015-5723 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2015-5723 and fix it if it is affected.

What it is: CVE-2015-5723 is a high-severity vulnerability in Debian Debian Linux, published on 7 Jun 2016. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2015-5723 in the wild and no public exploit code.

Affected packages and fixed versions:
- doctrine/cache (Packagist): affected from 1.0.0; fixed in 1.3.2
- doctrine/cache (Packagist): affected from 1.0.0; fixed in 1.3.2
- doctrine/cache (Packagist): affected from 1.4.0; fixed in 1.4.2
- doctrine/cache (Packagist): affected from 1.4.0; fixed in 1.4.2
- aws/aws-sdk-php (Packagist): affected from 3.0.0; fixed in 3.2.1
- aws/aws-sdk-php (Packagist): affected from 3.0.0; fixed in 3.2.1
- doctrine/annotations (Packagist): affected all versions; fixed in 1.2.7
- doctrine/annotations (Packagist): affected all versions; fixed in 1.2.7
- doctrine/common (Packagist): affected all versions; fixed in 2.4.3
- doctrine/common (Packagist): affected all versions; fixed in 2.4.3
- doctrine/common (Packagist): affected from 2.5.0-stable; fixed in 2.5.1
- doctrine/common (Packagist): affected from 2.5.0-stable; fixed in 2.5.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2015-5723/ (Markdown: https://insights.sbomify.com/CVE-2015-5723/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2015-5723
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2015-5723
- OSV: https://osv.dev/vulnerability/CVE-2015-5723

---
From sbomify Insights: https://insights.sbomify.com/CVE-2015-5723/
Summaries are generated and may contain mistakes; the official description above is the record.
