CVE-2015-5963 Django denial of service via empty session record creation
Remote attackers can cause denial of service by exhausting session storage through repeated logout requests in Django.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2015-5963?
CVE-2015-5963 is a medium-severity denial of service vulnerability in Canonical Ubuntu Linux, published on 24 Aug 2015. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
contrib.sessions.middleware.SessionMiddleware in Django 1.8.x before 1.8.4, 1.7.x before 1.7.10, 1.4.x before 1.4.22, and possibly other versions allows remote attackers to cause a denial of service (session store consumption or session record removal) via a large number of requests to contrib.auth.views.logout, which triggers the creation of an empty session record.
Weakness: CWE-399
Which versions are affected by CVE-2015-5963?
7 open source packages ship an affected version, including django and Django. It affects 3 products.
| Package | Affected | Fixed in |
|---|---|---|
django PyPI | From 1.4 | 1.4.22 |
django PyPI | From 1.7 | 1.7.10 |
django PyPI | From 1.8 | 1.8.4, 1.7.10, 1.4.22 |
django PyPI | From 1.8 | 1.8.4 |
Django PyPI | From 1.4 | 1.4.22 |
Django PyPI | From 1.7 | 1.7.10 |
1 more packages
Django PyPI | From 1.8 | 1.8.4 |
Linux distribution packages (3)
python-django Red Hat:openstack:7::el7 | All versions | 0:1.8.4-1.el7 |
python-django-bash-completion Red Hat:openstack:7::el7 | All versions | 0:1.8.4-1.el7 |
python-django-doc Red Hat:openstack:7::el7 | All versions | 0:1.8.4-1.el7 |
Products include Canonical Ubuntu Linux, Djangoproject Django, Oracle Solaris.
How do I fix CVE-2015-5963?
Upgrade django to a fixed version for your release line: 1.4.22, 1.7.10 or 1.8.4.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2015-5963 being exploited?
There is no known exploitation of CVE-2015-5963 in the wild and no public exploit code.
Other vulnerabilities in Canonical Ubuntu Linux
Sources
Also known as DEBIAN-CVE-2015-5963, GHSA-pgxh-wfw4-jx2v, PYSEC-2015-22, RHSA-2015:1876, UBUNTU-CVE-2015-5963.