# CVE-2015-5963: Django denial of service via empty session record creation

> Remote attackers can cause denial of service by exhausting session storage through repeated logout requests in Django.

- **Severity:** Medium 5.0 (`AV:N/AC:L/Au:N/C:N/I:N/A:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Aug 2015
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2015-5963, GHSA-pgxh-wfw4-jx2v, PYSEC-2015-22, RHSA-2015:1876, UBUNTU-CVE-2015-5963

## What is CVE-2015-5963?

CVE-2015-5963 is a medium-severity denial of service vulnerability in Canonical Ubuntu Linux, published on 24 Aug 2015. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

contrib.sessions.middleware.SessionMiddleware in Django 1.8.x before 1.8.4, 1.7.x before 1.7.10, 1.4.x before 1.4.22, and possibly other versions allows remote attackers to cause a denial of service (session store consumption or session record removal) via a large number of requests to contrib.auth.views.logout, which triggers the creation of an empty session record.

Weakness: CWE-399

## Which versions are affected by CVE-2015-5963?

7 open source packages ship an affected version, including django and Django. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `django` | PyPI | From 1.4 | 1.4.22 |
| `django` | PyPI | From 1.7 | 1.7.10 |
| `django` | PyPI | From 1.8 | 1.8.4, 1.7.10, 1.4.22 |
| `django` | PyPI | From 1.8 | 1.8.4 |
| `Django` | PyPI | From 1.4 | 1.4.22 |
| `Django` | PyPI | From 1.7 | 1.7.10 |
| `Django` | PyPI | From 1.8 | 1.8.4 |
| `python-django` | Red Hat:openstack:7::el7 | All versions | 0:1.8.4-1.el7 |
| `python-django-bash-completion` | Red Hat:openstack:7::el7 | All versions | 0:1.8.4-1.el7 |
| `python-django-doc` | Red Hat:openstack:7::el7 | All versions | 0:1.8.4-1.el7 |

Products: Canonical Ubuntu Linux, Djangoproject Django, Oracle Solaris.

## How do I fix CVE-2015-5963?

Upgrade django to a fixed version for your release line: 1.4.22, 1.7.10 or 1.8.4.

## Is CVE-2015-5963 being exploited?

There is no known exploitation of CVE-2015-5963 in the wild and no public exploit code.

## Other vulnerabilities in Canonical Ubuntu Linux

- [CVE-2020-11651](https://insights.sbomify.com/CVE-2020-11651/): SaltStack Salt Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2020-7247](https://insights.sbomify.com/CVE-2020-7247/): OpenSMTPD Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2019-16928](https://insights.sbomify.com/CVE-2019-16928/): Exim Out-of-bounds Write (critical 9.8, exploited in the wild)
- [CVE-2018-6789](https://insights.sbomify.com/CVE-2018-6789/): Exim Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2015-2590](https://insights.sbomify.com/CVE-2015-2590/): Oracle Java SE and Java SE Embedded Remote Code Execution (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2015-5963 and fix it if it is affected.

What it is: CVE-2015-5963 is a medium-severity denial of service vulnerability in Canonical Ubuntu Linux, published on 24 Aug 2015. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2015-5963 in the wild and no public exploit code.

Affected packages and fixed versions:
- django (PyPI): affected from 1.4; fixed in 1.4.22
- django (PyPI): affected from 1.7; fixed in 1.7.10
- django (PyPI): affected from 1.8; fixed in 1.8.4, 1.7.10, 1.4.22
- django (PyPI): affected from 1.8; fixed in 1.8.4
- Django (PyPI): affected from 1.4; fixed in 1.4.22
- Django (PyPI): affected from 1.7; fixed in 1.7.10
- Django (PyPI): affected from 1.8; fixed in 1.8.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2015-5963/ (Markdown: https://insights.sbomify.com/CVE-2015-5963/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2015-5963
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2015-5963
- OSV: https://osv.dev/vulnerability/CVE-2015-5963

---
From sbomify Insights: https://insights.sbomify.com/CVE-2015-5963/
Summaries are generated and may contain mistakes; the official description above is the record.
