CVE-2015-5964 Denial-of-service possibility in logout() view by filling session store
Remote attackers can cause denial of service by consuming session store resources through empty session creation in Django.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2015-5964?
CVE-2015-5964 is a medium-severity denial of service vulnerability in Canonical Ubuntu Linux, published on 24 Aug 2015. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
The (1) contrib.sessions.backends.base.SessionBase.flush and (2) cache_db.SessionStore.flush functions in Django 1.7.x before 1.7.10, 1.4.x before 1.4.22, and possibly other versions create empty sessions in certain circumstances, which allows remote attackers to cause a denial of service (session store consumption) via unspecified vectors.
Weakness: CWE-399
Which versions are affected by CVE-2015-5964?
5 open source packages ship an affected version, including django and Django. It affects 3 products.
| Package | Affected | Fixed in |
|---|---|---|
django PyPI | From 1.4 | 1.4.22 |
django PyPI | From 1.7 | 1.7.10, 1.4.22 |
django PyPI | From 1.7 | 1.7.10 |
Django PyPI | From 1.4 | 1.4.22 |
Django PyPI | From 1.7 | 1.7.10 |
Products include Canonical Ubuntu Linux, Djangoproject Django, Oracle Solaris.
How do I fix CVE-2015-5964?
Upgrade django to a fixed version for your release line: 1.4.22 or 1.7.10.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2015-5964 being exploited?
There is no known exploitation of CVE-2015-5964 in the wild and no public exploit code.
Other vulnerabilities in Canonical Ubuntu Linux
Sources
Also known as DEBIAN-CVE-2015-5964, GHSA-x38m-486c-2wr9, PYSEC-2015-23, UBUNTU-CVE-2015-5964.