{"answers":{"affected":"3 open source packages ship an affected version, including ansible. It affects 1 product.","exploited":"There is no known exploitation of CVE-2015-6240 in the wild and no public exploit code.","fix":"Upgrade ansible to 1.9.2 or later.","what":"CVE-2015-6240 is a high-severity path traversal vulnerability in n/a, published on 7 Jun 2017. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2015-6240 and fix it if it is affected.\n\nWhat it is: CVE-2015-6240 is a high-severity path traversal vulnerability in n/a, published on 7 Jun 2017. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2015-6240 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- ansible (PyPI): affected all versions; fixed in 1.9.2\n- ansible (PyPI): affected all versions; fixed in 1.9.2\n- ansible (PyPI): affected all versions; fixed in 1.9.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2015-6240/ (Markdown: https://insights.sbomify.com/CVE-2015-6240/index.md)","id":"CVE-2015-6240","markdown":"https://insights.sbomify.com/CVE-2015-6240/index.md","name":"CVE-2015-6240","record":{"aliases":["DEBIAN-CVE-2015-6240","GHSA-wwwh-47wp-m522","PYSEC-2017-3","UBUNTU-CVE-2015-6240"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["privilege_escalation"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Ansible automation tool","requires_auth":"low_privilege","summary":"Local users can escape restricted environments in Ansible via symlink attacks in chroot, jail, and zone plugins.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"ansible","vendor":"redhat"}],"cvss":{"score":7.8,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-59","name":"Improper Link Resolution Before File Access"}],"description":"The chroot, jail, and zone connection plugins in ansible before 1.9.2 allow local users to escape a restricted environment via a symlink attack.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Ansible Sandbox Escape via Symlink Attack","id":"CVE-2015-6240","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"path_traversal","year":"2015"},"n_packages":3,"n_references":5,"next":{"headline":"Denial of service in n/a","id":"CVE-2015-6241"},"packages":[{"ecosystem":"PyPI","fixed":["1.9.2"],"introduced":["0"],"last_affected":[],"package":"ansible","purl":null,"source":"GHSA-wwwh-47wp-m522"},{"ecosystem":"PyPI","fixed":["1.9.2"],"introduced":["0"],"last_affected":[],"package":"ansible","purl":"pkg:pypi/ansible","source":"GHSA-wwwh-47wp-m522"},{"ecosystem":"PyPI","fixed":["1.9.2"],"introduced":["0"],"last_affected":[],"package":"ansible","purl":"pkg:pypi/ansible","source":"PYSEC-2017-3"}],"prev":{"headline":"Cross-site scripting in n/a","id":"CVE-2015-6238"},"products":["n/a"],"published":"2017-06-07","related":[{"cvss_score":9.8,"headline":"Ansible Remote Code Execution","id":"CVE-2014-4657","kev_date_added":null,"published":"2020-02-20"},{"cvss_score":9.8,"headline":"Ansible Arbitrary Code Execution","id":"CVE-2014-4966","kev_date_added":null,"published":"2020-02-18"},{"cvss_score":9.8,"headline":"Ansible Arbitrary Code Execution","id":"CVE-2014-4967","kev_date_added":null,"published":"2020-02-18"},{"cvss_score":9.8,"headline":"Ansible Insertion of Sensitive Information into Log File vulnerability","id":"CVE-2017-7550","kev_date_added":null,"published":"2017-11-21"},{"cvss_score":8.8,"headline":"Ansible Arbitrary Code Execution","id":"CVE-2014-3498","kev_date_added":null,"published":"2017-06-08"},{"cvss_score":8,"headline":"Ansible Arbitrary Code Execution","id":"CVE-2017-7466","kev_date_added":null,"published":"2018-06-22"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Local users can escape restricted environments in Ansible via symlink attacks in chroot, jail, and zone plugins.","url":"https://insights.sbomify.com/CVE-2015-6240/"}