# CVE-2015-6240: Ansible Sandbox Escape via Symlink Attack

> Local users can escape restricted environments in Ansible via symlink attacks in chroot, jail, and zone plugins.

- **Severity:** High 7.8 (`CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Jun 2017
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2015-6240, GHSA-wwwh-47wp-m522, PYSEC-2017-3, UBUNTU-CVE-2015-6240

## What is CVE-2015-6240?

CVE-2015-6240 is a high-severity path traversal vulnerability in n/a, published on 7 Jun 2017. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

The chroot, jail, and zone connection plugins in ansible before 1.9.2 allow local users to escape a restricted environment via a symlink attack.

Weakness: CWE-59 (Improper Link Resolution Before File Access)

## Which versions are affected by CVE-2015-6240?

3 open source packages ship an affected version, including ansible. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ansible` | PyPI | All versions | 1.9.2 |
| `ansible` | PyPI | All versions | 1.9.2 |
| `ansible` | PyPI | All versions | 1.9.2 |

Products: Redhat Ansible.

## How do I fix CVE-2015-6240?

Upgrade ansible to 1.9.2 or later.

## Is CVE-2015-6240 being exploited?

There is no known exploitation of CVE-2015-6240 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2014-4657](https://insights.sbomify.com/CVE-2014-4657/): Ansible Remote Code Execution (critical 9.8)
- [CVE-2014-4966](https://insights.sbomify.com/CVE-2014-4966/): Ansible Arbitrary Code Execution (critical 9.8)
- [CVE-2014-4967](https://insights.sbomify.com/CVE-2014-4967/): Ansible Arbitrary Code Execution (critical 9.8)
- [CVE-2017-7550](https://insights.sbomify.com/CVE-2017-7550/): Ansible Insertion of Sensitive Information into Log File vulnerability (critical 9.8)
- [CVE-2014-3498](https://insights.sbomify.com/CVE-2014-3498/): Ansible Arbitrary Code Execution (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2015-6240 and fix it if it is affected.

What it is: CVE-2015-6240 is a high-severity path traversal vulnerability in n/a, published on 7 Jun 2017. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2015-6240 in the wild and no public exploit code.

Affected packages and fixed versions:
- ansible (PyPI): affected all versions; fixed in 1.9.2
- ansible (PyPI): affected all versions; fixed in 1.9.2
- ansible (PyPI): affected all versions; fixed in 1.9.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2015-6240/ (Markdown: https://insights.sbomify.com/CVE-2015-6240/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2015-6240
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2015-6240
- OSV: https://osv.dev/vulnerability/CVE-2015-6240

---
From sbomify Insights: https://insights.sbomify.com/CVE-2015-6240/
Summaries are generated and may contain mistakes; the official description above is the record.
