# CVE-2015-6420: Insecure Deserialization in Apache Commons Collection

> Remote attackers can execute arbitrary commands on various Cisco products via crafted serialized Java objects exploiting the Apache Commons Collections library.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Dec 2015
- **Updated:** 7 Oct 2026
- **Also known as:** CLSA-2026-1777509604, CLSA-2026-1778114665, CLSA-2026-1789362482, GHSA-6hgm-866r-3cjv, ROOT-APP-MAVEN-CVE-2015-6420

## What is CVE-2015-6420?

CVE-2015-6420 is a critical unsafe deserialization vulnerability in n/a, published on 15 Dec 2015. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Serialized-object interfaces in certain Cisco Collaboration and Social Media; Endpoint Clients and Client Software; Network Application, Service, and Acceleration; Network and Content Security Devices; Network Management and Provisioning; Routing and Switching - Enterprise and Service Provider; Unified Computing; Voice and Unified Communications Devices; Video, Streaming, TelePresence, and Transcoding Devices; Wireless; and Cisco Hosted Services products allow remote attackers to execute arbitrary commands via a crafted serialized Java object, related to the Apache Commons Collections (ACC) library.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2015-6420?

10 open source packages ship an affected version, including commons-collections:commons-collections, net.sourceforge.collections:collections-generic and org.apache.commons:commons-collections4. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `commons-collections:commons-collections` | Maven | All versions | 3.2.2 |
| `commons-collections:commons-collections` | Maven | All versions | 3.2.2 |
| `net.sourceforge.collections:collections-generic` | Maven | All versions to 4.0.1 | None |
| `net.sourceforge.collections:collections-generic` | Maven | All versions to 4.0.1 | None |
| `org.apache.commons:commons-collections4` | Maven | All versions | 4.1 |
| `org.apache.commons:commons-collections4` | Maven | All versions | 4.1 |
| `org.apache.servicemix.bundles:org.apache.servicemix.bundles.collections-generic` | Maven | All versions to 4.01 | None |
| `org.apache.servicemix.bundles:org.apache.servicemix.bundles.collections-generic` | Maven | All versions to 4.01 | None |
| `org.apache.servicemix.bundles:org.apache.servicemix.bundles.commons-collections` | Maven | All versions to 3.2.1 | None |
| `org.apache.servicemix.bundles:org.apache.servicemix.bundles.commons-collections` | Maven | All versions to 3.2.1 | None |

Products: Apache Commons Collections.

## How do I fix CVE-2015-6420?

Upgrade commons-collections:commons-collections to 3.2.2 or later.

## Is CVE-2015-6420 being exploited?

There is no known exploitation of CVE-2015-6420 in the wild and no public exploit code.

Public exploit code:

- https://github.com/Leeziao/CVE-2015-6420 (github_poc): https://github.com/Leeziao/CVE-2015-6420

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2015-6420 and fix it if it is affected.

What it is: CVE-2015-6420 is a critical unsafe deserialization vulnerability in n/a, published on 15 Dec 2015. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2015-6420 in the wild and no public exploit code.

Affected packages and fixed versions:
- commons-collections:commons-collections (Maven): affected all versions; fixed in 3.2.2
- commons-collections:commons-collections (Maven): affected all versions; fixed in 3.2.2
- net.sourceforge.collections:collections-generic (Maven): affected all versions up to 4.0.1; no fix listed
- net.sourceforge.collections:collections-generic (Maven): affected all versions up to 4.0.1; no fix listed
- org.apache.commons:commons-collections4 (Maven): affected all versions; fixed in 4.1
- org.apache.commons:commons-collections4 (Maven): affected all versions; fixed in 4.1
- org.apache.servicemix.bundles:org.apache.servicemix.bundles.collections-generic (Maven): affected all versions up to 4.01; no fix listed
- org.apache.servicemix.bundles:org.apache.servicemix.bundles.collections-generic (Maven): affected all versions up to 4.01; no fix listed
- org.apache.servicemix.bundles:org.apache.servicemix.bundles.commons-collections (Maven): affected all versions up to 3.2.1; no fix listed
- org.apache.servicemix.bundles:org.apache.servicemix.bundles.commons-collections (Maven): affected all versions up to 3.2.1; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2015-6420/ (Markdown: https://insights.sbomify.com/CVE-2015-6420/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2015-6420
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2015-6420
- OSV: https://osv.dev/vulnerability/CVE-2015-6420

---
From sbomify Insights: https://insights.sbomify.com/CVE-2015-6420/
Summaries are generated and may contain mistakes; the official description above is the record.
