{"answers":{"affected":"2 open source packages ship an affected version, including magento/core. It affects 1 product.","exploited":"There is no known exploitation of CVE-2015-6497 in the wild and no public exploit code.","fix":"Upgrade magento/core to 1.9.2.1 or later.","what":"CVE-2015-6497 is a high-severity code injection vulnerability in Magento Magento, published on 15 Jan 2020. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2015-6497 and fix it if it is affected.\n\nWhat it is: CVE-2015-6497 is a high-severity code injection vulnerability in Magento Magento, published on 15 Jan 2020. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2015-6497 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- magento/core (Packagist): affected all versions; fixed in 1.9.2.1\n- magento/core (Packagist): affected all versions; fixed in 1.9.2.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2015-6497/ (Markdown: https://insights.sbomify.com/CVE-2015-6497/index.md)","id":"CVE-2015-6497","markdown":"https://insights.sbomify.com/CVE-2015-6497/index.md","name":"CVE-2015-6497","record":{"aliases":["GHSA-j4fq-3fm7-wh5v"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Magento e-commerce platform","requires_auth":"low_privilege","summary":"Authenticated attackers can execute arbitrary PHP code via the productData parameter in Magento's API when running on vulnerable PHP versions.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"magento","vendor":"magento"}],"cvss":{"score":8.8,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"}],"description":"The create function in app/code/core/Mage/Catalog/Model/Product/Api/V2.php in Magento Community Edition (CE) before 1.9.2.1 and Enterprise Edition (EE) before 1.14.2.1, when used with PHP before 5.4.24 or 5.5.8, allows remote authenticated users to execute arbitrary PHP code via the productData parameter to index.php/api/v2_soap.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Magento arbitrary PHP code execution via the productData parameter","id":"CVE-2015-6497","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":"magento:magento","products":["magento:magento"],"type":"code_injection","year":"2015"},"n_packages":2,"n_references":5,"next":{"headline":"Auth bypass in n/a","id":"CVE-2015-6498"},"packages":[{"ecosystem":"Packagist","fixed":["1.9.2.1"],"introduced":["0"],"last_affected":[],"package":"magento/core","purl":null,"source":"GHSA-j4fq-3fm7-wh5v"},{"ecosystem":"Packagist","fixed":["1.9.2.1"],"introduced":["0"],"last_affected":[],"package":"magento/core","purl":"pkg:composer/magento/core","source":"GHSA-j4fq-3fm7-wh5v"}],"prev":{"headline":"Denial of service in n/a","id":"CVE-2015-6496"},"products":["n/a"],"published":"2020-01-15","related":[{"cvss_score":9.8,"headline":"Magento php object injection vulnerability","id":"CVE-2020-9664","kev_date_added":null,"published":"2020-07-22"},{"cvss_score":9.8,"headline":"Magento command injection vulnerability","id":"CVE-2020-9576","kev_date_added":null,"published":"2020-06-26"},{"cvss_score":9.8,"headline":"Magento command injection vulnerability","id":"CVE-2020-9578","kev_date_added":null,"published":"2020-06-26"},{"cvss_score":9.8,"headline":"Magento Security mitigation bypass vulnerability","id":"CVE-2020-9579","kev_date_added":null,"published":"2020-06-26"},{"cvss_score":9.8,"headline":"Magento Security mitigation bypass vulnerability","id":"CVE-2020-9580","kev_date_added":null,"published":"2020-06-26"},{"cvss_score":9.8,"headline":"Magento command injection vulnerability","id":"CVE-2020-9582","kev_date_added":null,"published":"2020-06-26"},{"cvss_score":9.8,"headline":"Magento command injection vulnerability","id":"CVE-2020-9583","kev_date_added":null,"published":"2020-06-26"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Authenticated attackers can execute arbitrary PHP code via the productData parameter in Magento's API when running on vulnerable PHP versions.","url":"https://insights.sbomify.com/CVE-2015-6497/"}