# CVE-2015-6497: Magento arbitrary PHP code execution via the productData parameter

> Authenticated attackers can execute arbitrary PHP code via the productData parameter in Magento's API when running on vulnerable PHP versions.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Jan 2020
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-j4fq-3fm7-wh5v

## What is CVE-2015-6497?

CVE-2015-6497 is a high-severity code injection vulnerability in Magento Magento, published on 15 Jan 2020. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

The create function in app/code/core/Mage/Catalog/Model/Product/Api/V2.php in Magento Community Edition (CE) before 1.9.2.1 and Enterprise Edition (EE) before 1.14.2.1, when used with PHP before 5.4.24 or 5.5.8, allows remote authenticated users to execute arbitrary PHP code via the productData parameter to index.php/api/v2_soap.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2015-6497?

2 open source packages ship an affected version, including magento/core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `magento/core` | Packagist | All versions | 1.9.2.1 |
| `magento/core` | Packagist | All versions | 1.9.2.1 |

Products: Magento Magento.

## How do I fix CVE-2015-6497?

Upgrade magento/core to 1.9.2.1 or later.

## Is CVE-2015-6497 being exploited?

There is no known exploitation of CVE-2015-6497 in the wild and no public exploit code.

## Other vulnerabilities in Magento Magento

- [CVE-2020-9664](https://insights.sbomify.com/CVE-2020-9664/): Magento php object injection vulnerability (critical 9.8)
- [CVE-2020-9576](https://insights.sbomify.com/CVE-2020-9576/): Magento command injection vulnerability (critical 9.8)
- [CVE-2020-9578](https://insights.sbomify.com/CVE-2020-9578/): Magento command injection vulnerability (critical 9.8)
- [CVE-2020-9579](https://insights.sbomify.com/CVE-2020-9579/): Magento Security mitigation bypass vulnerability (critical 9.8)
- [CVE-2020-9580](https://insights.sbomify.com/CVE-2020-9580/): Magento Security mitigation bypass vulnerability (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2015-6497 and fix it if it is affected.

What it is: CVE-2015-6497 is a high-severity code injection vulnerability in Magento Magento, published on 15 Jan 2020. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2015-6497 in the wild and no public exploit code.

Affected packages and fixed versions:
- magento/core (Packagist): affected all versions; fixed in 1.9.2.1
- magento/core (Packagist): affected all versions; fixed in 1.9.2.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2015-6497/ (Markdown: https://insights.sbomify.com/CVE-2015-6497/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2015-6497
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2015-6497
- OSV: https://osv.dev/vulnerability/CVE-2015-6497

---
From sbomify Insights: https://insights.sbomify.com/CVE-2015-6497/
Summaries are generated and may contain mistakes; the official description above is the record.
