{"answers":{"affected":"4 open source packages ship an affected version, including org.apache.activemq:activemq-broker and org.apache.activemq:activemq-jaas. It affects 2 products.","exploited":"There is no known exploitation of CVE-2015-6524 in the wild and no public exploit code.","fix":"Upgrade org.apache.activemq:activemq-broker to 5.10.2 or later.","what":"CVE-2015-6524 is a medium-severity authentication bypass vulnerability in Apache Activemq, published on 24 Aug 2015. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2015-6524 and fix it if it is affected.\n\nWhat it is: CVE-2015-6524 is a medium-severity authentication bypass vulnerability in Apache Activemq, published on 24 Aug 2015. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2015-6524 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.apache.activemq:activemq-broker (Maven): affected from 5.0.0; fixed in 5.10.2\n- org.apache.activemq:activemq-broker (Maven): affected from 5.0.0; fixed in 5.10.2\n- org.apache.activemq:activemq-jaas (Maven): affected from 5.0.0; fixed in 5.10.2\n- org.apache.activemq:activemq-jaas (Maven): affected from 5.0.0; fixed in 5.10.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2015-6524/ (Markdown: https://insights.sbomify.com/CVE-2015-6524/index.md)","id":"CVE-2015-6524","markdown":"https://insights.sbomify.com/CVE-2015-6524/index.md","name":"CVE-2015-6524","record":{"aliases":["DEBIAN-CVE-2015-6524","GHSA-23cr-5hr4-rgwv","UBUNTU-CVE-2015-6524"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["account_takeover","data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Apache ActiveMQ","requires_auth":"none","summary":"Remote attackers can brute force credentials in Apache ActiveMQ due to wildcard support in LDAP usernames, leading to unauthorized access.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"activemq","vendor":"apache"},{"product":"fedora","vendor":"fedoraproject"}],"cvss":{"score":5,"severity":"medium","source":"nvd","vector":"AV:N/AC:L/Au:N/C:P/I:N/A:N","version":"2.0"},"cwes":[{"id":"CWE-255","name":null}],"description":"The LDAPLoginModule implementation in the Java Authentication and Authorization Service (JAAS) in Apache ActiveMQ 5.x before 5.10.1 allows wildcard operators in usernames, which allows remote attackers to obtain credentials via a brute force attack. NOTE: this identifier was SPLIT from CVE-2014-3612 per ADT2 due to different vulnerability types.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Improper Input Validation in Apache ActiveMQ","id":"CVE-2015-6524","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":"apache:activemq","products":["apache:activemq","fedoraproject:fedora"],"type":"auth_bypass","year":"2015"},"n_packages":4,"n_references":3,"next":{"headline":"Integer overflow in n/a","id":"CVE-2015-6525"},"packages":[{"ecosystem":"Maven","fixed":["5.10.2"],"introduced":["5.0.0"],"last_affected":[],"package":"org.apache.activemq:activemq-broker","purl":null,"source":"GHSA-23cr-5hr4-rgwv"},{"ecosystem":"Maven","fixed":["5.10.2"],"introduced":["5.0.0"],"last_affected":[],"package":"org.apache.activemq:activemq-broker","purl":"pkg:maven/org.apache.activemq/activemq-broker","source":"GHSA-23cr-5hr4-rgwv"},{"ecosystem":"Maven","fixed":["5.10.2"],"introduced":["5.0.0"],"last_affected":[],"package":"org.apache.activemq:activemq-jaas","purl":null,"source":"GHSA-23cr-5hr4-rgwv"},{"ecosystem":"Maven","fixed":["5.10.2"],"introduced":["5.0.0"],"last_affected":[],"package":"org.apache.activemq:activemq-jaas","purl":"pkg:maven/org.apache.activemq/activemq-jaas","source":"GHSA-23cr-5hr4-rgwv"}],"prev":{"headline":"Cross-site request forgery in n/a","id":"CVE-2015-6523"},"products":["n/a"],"published":"2015-08-24","related":[{"cvss_score":10,"headline":"Apache ActiveMQ Deserialization of Untrusted Data","id":"CVE-2023-46604","kev_date_added":"2023-11-02","published":"2023-10-27"},{"cvss_score":9.8,"headline":"Apache ActiveMQ Improper Input Validation","id":"CVE-2016-3088","kev_date_added":"2022-02-10","published":"2016-06-01"},{"cvss_score":8.8,"headline":"Apache ActiveMQ Improper Input Validation","id":"CVE-2026-34197","kev_date_added":"2026-04-16","published":"2026-04-07"},{"cvss_score":9.8,"headline":"Remote code execution in Apache ActiveMQ","id":"CVE-2020-11998","kev_date_added":null,"published":"2020-09-10"},{"cvss_score":9.8,"headline":"Command Injection in Xstream","id":"CVE-2013-7285","kev_date_added":null,"published":"2019-05-15"},{"cvss_score":9.8,"headline":"Improper Restriction of XML External Entity Reference in Apache ActiveMQ","id":"CVE-2014-3600","kev_date_added":null,"published":"2017-10-27"},{"cvss_score":9.8,"headline":"Improper Input Validation in Apache ActiveMQ","id":"CVE-2015-5254","kev_date_added":null,"published":"2016-01-08"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote attackers can brute force credentials in Apache ActiveMQ due to wildcard support in LDAP usernames, leading to unauthorized access.","url":"https://insights.sbomify.com/CVE-2015-6524/"}