# CVE-2015-6524: Improper Input Validation in Apache ActiveMQ

> Remote attackers can brute force credentials in Apache ActiveMQ due to wildcard support in LDAP usernames, leading to unauthorized access.

- **Severity:** Medium 5.0 (`AV:N/AC:L/Au:N/C:P/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Aug 2015
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2015-6524, GHSA-23cr-5hr4-rgwv, UBUNTU-CVE-2015-6524

## What is CVE-2015-6524?

CVE-2015-6524 is a medium-severity authentication bypass vulnerability in Apache Activemq, published on 24 Aug 2015. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The LDAPLoginModule implementation in the Java Authentication and Authorization Service (JAAS) in Apache ActiveMQ 5.x before 5.10.1 allows wildcard operators in usernames, which allows remote attackers to obtain credentials via a brute force attack. NOTE: this identifier was SPLIT from CVE-2014-3612 per ADT2 due to different vulnerability types.

Weakness: CWE-255

## Which versions are affected by CVE-2015-6524?

4 open source packages ship an affected version, including org.apache.activemq:activemq-broker and org.apache.activemq:activemq-jaas. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.activemq:activemq-broker` | Maven | From 5.0.0 | 5.10.2 |
| `org.apache.activemq:activemq-broker` | Maven | From 5.0.0 | 5.10.2 |
| `org.apache.activemq:activemq-jaas` | Maven | From 5.0.0 | 5.10.2 |
| `org.apache.activemq:activemq-jaas` | Maven | From 5.0.0 | 5.10.2 |

Products: Apache Activemq, Fedoraproject Fedora.

## How do I fix CVE-2015-6524?

Upgrade org.apache.activemq:activemq-broker to 5.10.2 or later.

## Is CVE-2015-6524 being exploited?

There is no known exploitation of CVE-2015-6524 in the wild and no public exploit code.

## Other vulnerabilities in Apache Activemq

- [CVE-2023-46604](https://insights.sbomify.com/CVE-2023-46604/): Apache ActiveMQ Deserialization of Untrusted Data (critical 10.0, exploited in the wild)
- [CVE-2016-3088](https://insights.sbomify.com/CVE-2016-3088/): Apache ActiveMQ Improper Input Validation (critical 9.8, exploited in the wild)
- [CVE-2026-34197](https://insights.sbomify.com/CVE-2026-34197/): Apache ActiveMQ Improper Input Validation (high 8.8, exploited in the wild)
- [CVE-2020-11998](https://insights.sbomify.com/CVE-2020-11998/): Remote code execution in Apache ActiveMQ (critical 9.8)
- [CVE-2013-7285](https://insights.sbomify.com/CVE-2013-7285/): Command Injection in Xstream (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2015-6524 and fix it if it is affected.

What it is: CVE-2015-6524 is a medium-severity authentication bypass vulnerability in Apache Activemq, published on 24 Aug 2015. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2015-6524 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.activemq:activemq-broker (Maven): affected from 5.0.0; fixed in 5.10.2
- org.apache.activemq:activemq-broker (Maven): affected from 5.0.0; fixed in 5.10.2
- org.apache.activemq:activemq-jaas (Maven): affected from 5.0.0; fixed in 5.10.2
- org.apache.activemq:activemq-jaas (Maven): affected from 5.0.0; fixed in 5.10.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2015-6524/ (Markdown: https://insights.sbomify.com/CVE-2015-6524/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2015-6524
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2015-6524
- OSV: https://osv.dev/vulnerability/CVE-2015-6524

---
From sbomify Insights: https://insights.sbomify.com/CVE-2015-6524/
Summaries are generated and may contain mistakes; the official description above is the record.
