# CVE-2015-6584: DataTable Vulnerable to Cross-Site Scripting

> Remote attackers can inject arbitrary web script or HTML via the scripts parameter in the DataTables plugin, requiring user interaction to execute.

- **Severity:** Medium 4.3 (`AV:N/AC:M/Au:N/C:N/I:P/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 11 Sep 2015
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2015-6584, GHSA-4mv4-gmmf-q382

## What is CVE-2015-6584?

CVE-2015-6584 is a medium-severity cross-site scripting vulnerability in n/a, published on 11 Sep 2015. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Cross-site scripting (XSS) vulnerability in the DataTables plugin 1.10.8 and earlier for jQuery allows remote attackers to inject arbitrary web script or HTML via the scripts parameter to media/unit_testing/templates/6776.php.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2015-6584?

4 open source packages ship an affected version, including datatables/datatables and datatables. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `datatables/datatables` | Packagist | All versions | 1.10.10 |
| `datatables/datatables` | Packagist | All versions | 1.10.10 |
| `datatables` | npm | All versions | 1.10.10 |
| `datatables` | npm | All versions | 1.10.10 |

Products: Sprymedia Datatables.

## How do I fix CVE-2015-6584?

Upgrade datatables/datatables to 1.10.10 or later.

## Is CVE-2015-6584 being exploited?

There is no known exploitation of CVE-2015-6584 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2025-11031](https://insights.sbomify.com/CVE-2025-11031/): DataTables examples.php path traversal (medium 6.9)
- [CVE-2021-36713](https://insights.sbomify.com/CVE-2021-36713/): Cross-site scripting in n/a (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2015-6584 and fix it if it is affected.

What it is: CVE-2015-6584 is a medium-severity cross-site scripting vulnerability in n/a, published on 11 Sep 2015. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2015-6584 in the wild and no public exploit code.

Affected packages and fixed versions:
- datatables/datatables (Packagist): affected all versions; fixed in 1.10.10
- datatables/datatables (Packagist): affected all versions; fixed in 1.10.10
- datatables (npm): affected all versions; fixed in 1.10.10
- datatables (npm): affected all versions; fixed in 1.10.10

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2015-6584/ (Markdown: https://insights.sbomify.com/CVE-2015-6584/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2015-6584
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2015-6584
- OSV: https://osv.dev/vulnerability/CVE-2015-6584

---
From sbomify Insights: https://insights.sbomify.com/CVE-2015-6584/
Summaries are generated and may contain mistakes; the official description above is the record.
