{"answers":{"affected":"2 open source packages ship an affected version, including org.jsoup:jsoup. It affects 2 products.","exploited":"There is no known exploitation of CVE-2015-6748 in the wild and no public exploit code.","fix":"Upgrade org.jsoup:jsoup to 1.8.3 or later.","what":"CVE-2015-6748 is a medium-severity cross-site scripting vulnerability in Debian Debian Linux, published on 25 Sep 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2015-6748 and fix it if it is affected.\n\nWhat it is: CVE-2015-6748 is a medium-severity cross-site scripting vulnerability in Debian Debian Linux, published on 25 Sep 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2015-6748 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.jsoup:jsoup (Maven): affected from 1.6.0; fixed in 1.8.3\n- org.jsoup:jsoup (Maven): affected from 1.6.0; fixed in 1.8.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2015-6748/ (Markdown: https://insights.sbomify.com/CVE-2015-6748/index.md)","id":"CVE-2015-6748","markdown":"https://insights.sbomify.com/CVE-2015-6748/index.md","name":"CVE-2015-6748","record":{"aliases":["DEBIAN-CVE-2015-6748","DLA-2075-1","GHSA-48rh-qgjr-xfj6","MGASA-2015-0340"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Java HTML parser","requires_auth":"none","summary":"An attacker can inject malicious scripts via jsoup, potentially leading to code execution in the context of the application using the library.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"debian_linux","vendor":"debian"},{"product":"jsoup","vendor":"jsoup"}],"cvss":{"score":6.1,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Cross-site scripting (XSS) vulnerability in jsoup before 1.8.3.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":"2024-05-31","github_poc":1,"max_poc_stars":0,"metasploit":0,"nuclei":0,"refs":[{"date":"2024-05-31T21:24:39Z","kind":"github_poc","ref":"https://github.com/epicosy/VUL4J-59","stars":0,"title":"jhy/jsoup with CVE-2015-6748"}],"tier":"poc_unverified"},"has_fix":true,"headline":"Improper Neutralization of Input During Web Page Generation in Jsoup","id":"CVE-2015-6748","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":"debian:debian_linux","products":["debian:debian_linux"],"type":"xss","year":"2015"},"n_packages":2,"n_references":7,"next":{"headline":"Memory corruption in n/a","id":"CVE-2015-6749"},"packages":[{"ecosystem":"Maven","fixed":["1.8.3"],"introduced":["1.6.0"],"last_affected":[],"package":"org.jsoup:jsoup","purl":null,"source":"GHSA-48rh-qgjr-xfj6"},{"ecosystem":"Maven","fixed":["1.8.3"],"introduced":["1.6.0"],"last_affected":[],"package":"org.jsoup:jsoup","purl":"pkg:maven/org.jsoup/jsoup","source":"GHSA-48rh-qgjr-xfj6"}],"prev":{"headline":"Information disclosure in n/a","id":"CVE-2015-6747"},"products":["n/a"],"published":"2017-09-25","related":[{"cvss_score":10,"headline":"ProFTPD Improper Access Control","id":"CVE-2015-3306","kev_date_added":"2026-10-08","published":"2015-05-18"},{"cvss_score":9.9,"headline":"RoundCube Webmail Deserialization of Untrusted Data","id":"CVE-2025-49113","kev_date_added":"2026-02-20","published":"2025-06-02"},{"cvss_score":9.8,"headline":"GNU InetUtils Argument Injection","id":"CVE-2026-24061","kev_date_added":"2026-01-26","published":"2026-01-21"},{"cvss_score":9.8,"headline":"Linux Kernel Improper Check for Unusual or Exceptional Conditions","id":"CVE-2025-39682","kev_date_added":"2026-09-18","published":"2025-09-05"},{"cvss_score":9.8,"headline":"Mozilla Firefox Use-After-Free","id":"CVE-2024-9680","kev_date_added":"2024-10-15","published":"2024-10-09"},{"cvss_score":9.8,"headline":"RARLAB UnRAR Directory Traversal","id":"CVE-2022-30333","kev_date_added":"2022-08-09","published":"2022-05-09"},{"cvss_score":9.8,"headline":"Roundcube Webmail SQL Injection","id":"CVE-2021-44026","kev_date_added":"2023-06-22","published":"2021-11-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-10-08","vendors":["n/a"]},"summary":"An attacker can inject malicious scripts via jsoup, potentially leading to code execution in the context of the application using the library.","url":"https://insights.sbomify.com/CVE-2015-6748/"}