# CVE-2015-6748: Improper Neutralization of Input During Web Page Generation in Jsoup

> An attacker can inject malicious scripts via jsoup, potentially leading to code execution in the context of the application using the library.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 25 Sep 2017
- **Updated:** 8 Oct 2026
- **Also known as:** DEBIAN-CVE-2015-6748, DLA-2075-1, GHSA-48rh-qgjr-xfj6, MGASA-2015-0340

## What is CVE-2015-6748?

CVE-2015-6748 is a medium-severity cross-site scripting vulnerability in Debian Debian Linux, published on 25 Sep 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Cross-site scripting (XSS) vulnerability in jsoup before 1.8.3.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2015-6748?

2 open source packages ship an affected version, including org.jsoup:jsoup. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jsoup:jsoup` | Maven | From 1.6.0 | 1.8.3 |
| `org.jsoup:jsoup` | Maven | From 1.6.0 | 1.8.3 |

Products: Debian Debian Linux, Jsoup Jsoup.

## How do I fix CVE-2015-6748?

Upgrade org.jsoup:jsoup to 1.8.3 or later.

## Is CVE-2015-6748 being exploited?

There is no known exploitation of CVE-2015-6748 in the wild and no public exploit code.

Public exploit code:

- jhy/jsoup with CVE-2015-6748 (github_poc): https://github.com/epicosy/VUL4J-59

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2015-6748 and fix it if it is affected.

What it is: CVE-2015-6748 is a medium-severity cross-site scripting vulnerability in Debian Debian Linux, published on 25 Sep 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2015-6748 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jsoup:jsoup (Maven): affected from 1.6.0; fixed in 1.8.3
- org.jsoup:jsoup (Maven): affected from 1.6.0; fixed in 1.8.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2015-6748/ (Markdown: https://insights.sbomify.com/CVE-2015-6748/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2015-6748
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2015-6748
- OSV: https://osv.dev/vulnerability/CVE-2015-6748

---
From sbomify Insights: https://insights.sbomify.com/CVE-2015-6748/
Summaries are generated and may contain mistakes; the official description above is the record.
