{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2015-6806 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2015-6806 is a medium-severity denial of service vulnerability in n/a, published on 28 Sep 2015. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2015-6806 and fix it if it is affected.\n\nWhat it is: CVE-2015-6806 is a medium-severity denial of service vulnerability in n/a, published on 28 Sep 2015. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2015-6806 in the wild and no public exploit code.\n\nAffected product: n/a. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2015-6806/ (Markdown: https://insights.sbomify.com/CVE-2015-6806/index.md)","id":"CVE-2015-6806","markdown":"https://insights.sbomify.com/CVE-2015-6806/index.md","name":"CVE-2015-6806","record":{"aliases":["DEBIAN-CVE-2015-6806","DLA-305-1","DSA-3352-1","GHSA-3cxx-6jhw-pqvg","MGASA-2015-0354","SUSE-SU-2019:1354-1","UBUNTU-CVE-2015-6806","USN-3996-1"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"GNU screen terminal","requires_auth":"none","summary":"Remote attackers can cause a denial of service in GNU screen via a crafted escape sequence with a large repeat count, leading to stack consumption.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"gnu_screen","vendor":"gnu"}],"cvss":{"score":5,"severity":"medium","source":"nvd","vector":"AV:N/AC:L/Au:N/C:N/I:N/A:P","version":"2.0"},"cwes":[{"id":"CWE-119","name":"Improper Restriction of Operations within the Bounds of a Memory Buffer"}],"description":"The MScrollV function in ansi.c in GNU screen 4.3.1 and earlier does not properly limit recursion, which allows remote attackers to cause a denial of service (stack consumption) via an escape sequence with a large repeat count value.","ecosystems":["SUSE:Linux Enterprise Desktop 12 SP3","SUSE:Linux Enterprise Desktop 12 SP4","SUSE:Linux Enterprise Server 12 SP3","SUSE:Linux Enterprise Server 12 SP4","SUSE:Linux Enterprise Server for SAP Applications 12 SP3","SUSE:Linux Enterprise Server for SAP Applications 12 SP4"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Denial of service in n/a","id":"CVE-2015-6806","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"denial_of_service","year":"2015"},"n_packages":6,"n_references":8,"next":{"headline":"Cross-site scripting in n/a","id":"CVE-2015-6807"},"packages":[{"ecosystem":"SUSE:Linux Enterprise Desktop 12 SP3","fixed":["4.0.4-23.3.3"],"introduced":["0"],"last_affected":[],"package":"screen","purl":"pkg:rpm/suse/screen\u0026distro=SUSE%20Linux%20Enterprise%20Desktop%2012%20SP3","source":"SUSE-SU-2019:1354-1"},{"ecosystem":"SUSE:Linux Enterprise Desktop 12 SP4","fixed":["4.0.4-23.3.3"],"introduced":["0"],"last_affected":[],"package":"screen","purl":"pkg:rpm/suse/screen\u0026distro=SUSE%20Linux%20Enterprise%20Desktop%2012%20SP4","source":"SUSE-SU-2019:1354-1"},{"ecosystem":"SUSE:Linux Enterprise Server 12 SP3","fixed":["4.0.4-23.3.3"],"introduced":["0"],"last_affected":[],"package":"screen","purl":"pkg:rpm/suse/screen\u0026distro=SUSE%20Linux%20Enterprise%20Server%2012%20SP3","source":"SUSE-SU-2019:1354-1"},{"ecosystem":"SUSE:Linux Enterprise Server 12 SP4","fixed":["4.0.4-23.3.3"],"introduced":["0"],"last_affected":[],"package":"screen","purl":"pkg:rpm/suse/screen\u0026distro=SUSE%20Linux%20Enterprise%20Server%2012%20SP4","source":"SUSE-SU-2019:1354-1"},{"ecosystem":"SUSE:Linux Enterprise Server for SAP Applications 12 SP3","fixed":["4.0.4-23.3.3"],"introduced":["0"],"last_affected":[],"package":"screen","purl":"pkg:rpm/suse/screen\u0026distro=SUSE%20Linux%20Enterprise%20Server%20for%20SAP%20Applications%2012%20SP3","source":"SUSE-SU-2019:1354-1"},{"ecosystem":"SUSE:Linux Enterprise Server for SAP Applications 12 SP4","fixed":["4.0.4-23.3.3"],"introduced":["0"],"last_affected":[],"package":"screen","purl":"pkg:rpm/suse/screen\u0026distro=SUSE%20Linux%20Enterprise%20Server%20for%20SAP%20Applications%2012%20SP4","source":"SUSE-SU-2019:1354-1"}],"prev":{"headline":"Cross-site scripting in n/a","id":"CVE-2015-6805"},"products":["n/a"],"published":"2015-09-28","related":[{"cvss_score":1.9,"headline":"Race condition in n/a","id":"CVE-2009-1215","kev_date_added":null,"published":"2009-04-01"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote attackers can cause a denial of service in GNU screen via a crafted escape sequence with a large repeat count, leading to stack consumption.","url":"https://insights.sbomify.com/CVE-2015-6806/"}