CVE-2015-6830 phpMyAdmin ReCaptcha bypass
Attackers can bypass reCaptcha protection in phpMyAdmin to facilitate brute-force credential guessing attacks.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2015-6830?
CVE-2015-6830 is a medium-severity vulnerability in Phpmyadmin Phpmyadmin, published on 14 Sep 2015. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
libraries/plugins/auth/AuthenticationCookie.class.php in phpMyAdmin 4.3.x before 4.3.13.2 and 4.4.x before 4.4.14.1 allows remote attackers to bypass a multiple-reCaptcha protection mechanism against brute-force credential guessing by providing a correct response to a single reCaptcha.
Weakness: CWE-200
Which versions are affected by CVE-2015-6830?
4 open source packages ship an affected version, including phpmyadmin/phpmyadmin. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
phpmyadmin/phpmyadmin Packagist | From 4.3.0 | 4.3.13.2 |
phpmyadmin/phpmyadmin Packagist | From 4.3.0 | 4.3.13.2 |
phpmyadmin/phpmyadmin Packagist | From 4.4.0 | 4.4.14.1 |
phpmyadmin/phpmyadmin Packagist | From 4.4.0 | 4.4.14.1 |
Products include Phpmyadmin Phpmyadmin.
How do I fix CVE-2015-6830?
Upgrade phpmyadmin/phpmyadmin to a fixed version for your release line: 4.3.13.2 or 4.4.14.1.
Is CVE-2015-6830 being exploited?
There is no known exploitation of CVE-2015-6830 in the wild and no public exploit code.
Public exploit code: 1 Exploit-DB entry.
Other vulnerabilities in Phpmyadmin Phpmyadmin
Sources
Also known as DEBIAN-CVE-2015-6830, GHSA-v6fh-vg22-r6cm, MGASA-2015-0366.