{"answers":{"affected":"4 open source packages ship an affected version, including phpmyadmin/phpmyadmin. It affects 1 product.","exploited":"There is no known exploitation of CVE-2015-6830 in the wild and no public exploit code.","fix":"Upgrade phpmyadmin/phpmyadmin to a fixed version for your release line: 4.3.13.2 or 4.4.14.1.","what":"CVE-2015-6830 is a medium-severity vulnerability in Phpmyadmin Phpmyadmin, published on 14 Sep 2015. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2015-6830 and fix it if it is affected.\n\nWhat it is: CVE-2015-6830 is a medium-severity vulnerability in Phpmyadmin Phpmyadmin, published on 14 Sep 2015. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2015-6830 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- phpmyadmin/phpmyadmin (Packagist): affected from 4.3.0; fixed in 4.3.13.2\n- phpmyadmin/phpmyadmin (Packagist): affected from 4.3.0; fixed in 4.3.13.2\n- phpmyadmin/phpmyadmin (Packagist): affected from 4.4.0; fixed in 4.4.14.1\n- phpmyadmin/phpmyadmin (Packagist): affected from 4.4.0; fixed in 4.4.14.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2015-6830/ (Markdown: https://insights.sbomify.com/CVE-2015-6830/index.md)","id":"CVE-2015-6830","markdown":"https://insights.sbomify.com/CVE-2015-6830/index.md","name":"CVE-2015-6830","record":{"aliases":["DEBIAN-CVE-2015-6830","GHSA-v6fh-vg22-r6cm","MGASA-2015-0366"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"phpMyAdmin","requires_auth":"none","summary":"Attackers can bypass reCaptcha protection in phpMyAdmin to facilitate brute-force credential guessing attacks.","user_interaction":"not_required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"phpmyadmin","vendor":"phpmyadmin"}],"cvss":{"score":5,"severity":"medium","source":"nvd","vector":"AV:N/AC:L/Au:N/C:P/I:N/A:N","version":"2.0"},"cwes":[{"id":"CWE-200","name":"Exposure of Sensitive Information to an Unauthorized Actor"}],"description":"libraries/plugins/auth/AuthenticationCookie.class.php in phpMyAdmin 4.3.x before 4.3.13.2 and 4.4.x before 4.4.14.1 allows remote attackers to bypass a multiple-reCaptcha protection mechanism against brute-force credential guessing by providing a correct response to a single reCaptcha.","ecosystems":["Packagist"],"exploits":{"exploitdb":1,"first_seen":"2025-08-18","github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[{"date":"2025-08-18","kind":"exploitdb","ref":"52414","stars":null,"title":"PHPMyAdmin 3.0 - Bruteforce Login Bypass"}],"tier":"poc_unverified"},"has_fix":true,"headline":"phpMyAdmin ReCaptcha bypass","id":"CVE-2015-6830","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":"phpmyadmin:phpmyadmin","products":["phpmyadmin:phpmyadmin"],"type":"security_feature_bypass","year":"2015"},"n_packages":4,"n_references":8,"next":{"headline":"Use after free in n/a","id":"CVE-2015-6831"},"packages":[{"ecosystem":"Packagist","fixed":["4.3.13.2"],"introduced":["4.3.0"],"last_affected":[],"package":"phpmyadmin/phpmyadmin","purl":null,"source":"GHSA-v6fh-vg22-r6cm"},{"ecosystem":"Packagist","fixed":["4.3.13.2"],"introduced":["4.3.0"],"last_affected":[],"package":"phpmyadmin/phpmyadmin","purl":"pkg:composer/phpmyadmin/phpmyadmin","source":"GHSA-v6fh-vg22-r6cm"},{"ecosystem":"Packagist","fixed":["4.4.14.1"],"introduced":["4.4.0"],"last_affected":[],"package":"phpmyadmin/phpmyadmin","purl":null,"source":"GHSA-v6fh-vg22-r6cm"},{"ecosystem":"Packagist","fixed":["4.4.14.1"],"introduced":["4.4.0"],"last_affected":[],"package":"phpmyadmin/phpmyadmin","purl":"pkg:composer/phpmyadmin/phpmyadmin","source":"GHSA-v6fh-vg22-r6cm"}],"prev":{"headline":"SQL injection in n/a","id":"CVE-2015-6829"},"products":["n/a"],"published":"2015-09-14","related":[{"cvss_score":10,"headline":"Misconfiguration in n/a","id":"CVE-2008-7251","kev_date_added":null,"published":"2010-01-19"},{"cvss_score":10,"headline":"phpMyAdmin unsafely handles temporary files","id":"CVE-2008-7252","kev_date_added":null,"published":"2010-01-19"},{"cvss_score":10,"headline":"Other in n/a","id":"CVE-2007-0203","kev_date_added":null,"published":"2007-01-11"},{"cvss_score":10,"headline":"Command injection in n/a","id":"CVE-2004-1147","kev_date_added":null,"published":"2004-12-15"},{"cvss_score":9.8,"headline":"phpmyadmin contains SQL Injection vulnerability","id":"CVE-2020-22452","kev_date_added":null,"published":"2023-01-26"},{"cvss_score":9.8,"headline":"phpMyAdmin SQL injection in Designer feature","id":"CVE-2019-11768","kev_date_added":null,"published":"2019-06-05"},{"cvss_score":9.8,"headline":"phpMyAdmin SQL injection in Designer feature","id":"CVE-2019-6798","kev_date_added":null,"published":"2019-01-26"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"GPL-2.0-or-later","name":"Exploit-DB"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Attackers can bypass reCaptcha protection in phpMyAdmin to facilitate brute-force credential guessing attacks.","url":"https://insights.sbomify.com/CVE-2015-6830/"}