# CVE-2015-6830: phpMyAdmin ReCaptcha bypass

> Attackers can bypass reCaptcha protection in phpMyAdmin to facilitate brute-force credential guessing attacks.

- **Severity:** Medium 5.0 (`AV:N/AC:L/Au:N/C:P/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Sep 2015
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2015-6830, GHSA-v6fh-vg22-r6cm, MGASA-2015-0366

## What is CVE-2015-6830?

CVE-2015-6830 is a medium-severity vulnerability in Phpmyadmin Phpmyadmin, published on 14 Sep 2015. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

libraries/plugins/auth/AuthenticationCookie.class.php in phpMyAdmin 4.3.x before 4.3.13.2 and 4.4.x before 4.4.14.1 allows remote attackers to bypass a multiple-reCaptcha protection mechanism against brute-force credential guessing by providing a correct response to a single reCaptcha.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2015-6830?

4 open source packages ship an affected version, including phpmyadmin/phpmyadmin. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `phpmyadmin/phpmyadmin` | Packagist | From 4.3.0 | 4.3.13.2 |
| `phpmyadmin/phpmyadmin` | Packagist | From 4.3.0 | 4.3.13.2 |
| `phpmyadmin/phpmyadmin` | Packagist | From 4.4.0 | 4.4.14.1 |
| `phpmyadmin/phpmyadmin` | Packagist | From 4.4.0 | 4.4.14.1 |

Products: Phpmyadmin Phpmyadmin.

## How do I fix CVE-2015-6830?

Upgrade phpmyadmin/phpmyadmin to a fixed version for your release line: 4.3.13.2 or 4.4.14.1.

## Is CVE-2015-6830 being exploited?

There is no known exploitation of CVE-2015-6830 in the wild and no public exploit code.

Public exploit code:

- PHPMyAdmin 3.0 - Bruteforce Login Bypass (exploitdb)

## Other vulnerabilities in Phpmyadmin Phpmyadmin

- [CVE-2008-7251](https://insights.sbomify.com/CVE-2008-7251/): Misconfiguration in n/a (critical 10.0)
- [CVE-2008-7252](https://insights.sbomify.com/CVE-2008-7252/): phpMyAdmin unsafely handles temporary files (critical 10.0)
- [CVE-2007-0203](https://insights.sbomify.com/CVE-2007-0203/): Other in n/a (critical 10.0)
- [CVE-2004-1147](https://insights.sbomify.com/CVE-2004-1147/): Command injection in n/a (critical 10.0)
- [CVE-2020-22452](https://insights.sbomify.com/CVE-2020-22452/): phpmyadmin contains SQL Injection vulnerability (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2015-6830 and fix it if it is affected.

What it is: CVE-2015-6830 is a medium-severity vulnerability in Phpmyadmin Phpmyadmin, published on 14 Sep 2015. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2015-6830 in the wild and no public exploit code.

Affected packages and fixed versions:
- phpmyadmin/phpmyadmin (Packagist): affected from 4.3.0; fixed in 4.3.13.2
- phpmyadmin/phpmyadmin (Packagist): affected from 4.3.0; fixed in 4.3.13.2
- phpmyadmin/phpmyadmin (Packagist): affected from 4.4.0; fixed in 4.4.14.1
- phpmyadmin/phpmyadmin (Packagist): affected from 4.4.0; fixed in 4.4.14.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2015-6830/ (Markdown: https://insights.sbomify.com/CVE-2015-6830/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2015-6830
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2015-6830
- OSV: https://osv.dev/vulnerability/CVE-2015-6830

---
From sbomify Insights: https://insights.sbomify.com/CVE-2015-6830/
Summaries are generated and may contain mistakes; the official description above is the record.
