# CVE-2015-6926: OXID eShop user impersonation vulnerability

> Remote attackers can impersonate users in OXID eShop by exploiting a flaw in OpenID Single Sign-On authentication token validation.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Jan 2018
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-4c39-hj99-5h2r

## What is CVE-2015-6926?

CVE-2015-6926 is a high-severity authentication bypass vulnerability in n/a, published on 19 Jan 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The OpenID Single Sign-On authentication functionality in OXID eShop before 4.5.0 allows remote attackers to impersonate users via the email address in a crafted authentication token.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2015-6926?

2 open source packages ship an affected version, including oxid-esales/oxideshop-ce. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `oxid-esales/oxideshop-ce` | Packagist | All versions | 4.5.0 |
| `oxid-esales/oxideshop-ce` | Packagist | All versions | 4.5.0 |

Products: Oxid-Esales Eshop.

## How do I fix CVE-2015-6926?

Upgrade oxid-esales/oxideshop-ce to 4.5.0 or later.

## Is CVE-2015-6926 being exploited?

There is no known exploitation of CVE-2015-6926 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2019-13026](https://insights.sbomify.com/CVE-2019-13026/): SQL injection in n/a (critical 9.8)
- [CVE-2018-20715](https://insights.sbomify.com/CVE-2018-20715/): SQL injection in n/a (critical 9.8)
- [CVE-2019-17062](https://insights.sbomify.com/CVE-2019-17062/): Auth bypass in n/a (high 8.8)
- [CVE-2018-12579](https://insights.sbomify.com/CVE-2018-12579/): Auth bypass in n/a (high 8.1)
- [CVE-2024-56526](https://insights.sbomify.com/CVE-2024-56526/): OXID eShop May Display User Information (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2015-6926 and fix it if it is affected.

What it is: CVE-2015-6926 is a high-severity authentication bypass vulnerability in n/a, published on 19 Jan 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2015-6926 in the wild and no public exploit code.

Affected packages and fixed versions:
- oxid-esales/oxideshop-ce (Packagist): affected all versions; fixed in 4.5.0
- oxid-esales/oxideshop-ce (Packagist): affected all versions; fixed in 4.5.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2015-6926/ (Markdown: https://insights.sbomify.com/CVE-2015-6926/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2015-6926
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2015-6926
- OSV: https://osv.dev/vulnerability/CVE-2015-6926

---
From sbomify Insights: https://insights.sbomify.com/CVE-2015-6926/
Summaries are generated and may contain mistakes; the official description above is the record.
