# CVE-2015-7225: Tinfoil Devise-two-factor does not "burn" a successfully validated one-time password (OTP)

> Attackers can bypass two-factor authentication by replaying one-time passwords, allowing unauthorized account access if credentials are compromised.

- **Severity:** Medium 5.3 (`CVSS:3.0/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Sep 2017
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2015-7225, GHSA-x489-jjwm-52g7

## What is CVE-2015-7225?

CVE-2015-7225 is a medium-severity vulnerability in n/a, published on 6 Sep 2017. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Tinfoil Devise-two-factor before 2.0.0 does not strictly follow section 5.2 of RFC 6238 and does not "burn" a successfully validated one-time password (aka OTP), which allows remote or physically proximate attackers with a target user's login credentials to log in as said user by obtaining the OTP through performing a man-in-the-middle attack between the provider and verifier, or shoulder surfing, and replaying the OTP in the current time-step.

Weakness: CWE-254

## Which versions are affected by CVE-2015-7225?

2 open source packages ship an affected version, including devise-two-factor. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `devise-two-factor` | RubyGems | All versions | 2.0.0 |
| `devise-two-factor` | RubyGems | All versions | 2.0.0 |

Products: Tinfoilsecurity Devise-Two-Factor.

## How do I fix CVE-2015-7225?

Upgrade devise-two-factor to 2.0.0 or later.

## Is CVE-2015-7225 being exploited?

There is no known exploitation of CVE-2015-7225 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2024-8796](https://insights.sbomify.com/CVE-2024-8796/): Insufficient Default OTP Shared Secret Length (medium 6.0)
- [CVE-2021-43177](https://insights.sbomify.com/CVE-2021-43177/): Improper one time password handling in devise-two-factor (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2015-7225 and fix it if it is affected.

What it is: CVE-2015-7225 is a medium-severity vulnerability in n/a, published on 6 Sep 2017. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2015-7225 in the wild and no public exploit code.

Affected packages and fixed versions:
- devise-two-factor (RubyGems): affected all versions; fixed in 2.0.0
- devise-two-factor (RubyGems): affected all versions; fixed in 2.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2015-7225/ (Markdown: https://insights.sbomify.com/CVE-2015-7225/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2015-7225
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2015-7225
- OSV: https://osv.dev/vulnerability/CVE-2015-7225

---
From sbomify Insights: https://insights.sbomify.com/CVE-2015-7225/
Summaries are generated and may contain mistakes; the official description above is the record.
