{"answers":{"affected":"4 open source packages ship an affected version, including ldapauth and ldapauth-fork. It affects 1 product.","exploited":"There is no known exploitation of CVE-2015-7294 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2015-7294 is a high-severity vulnerability in n/a, published on 6 Sep 2017. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2015-7294 and fix it if it is affected.\n\nWhat it is: CVE-2015-7294 is a high-severity vulnerability in n/a, published on 6 Sep 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2015-7294 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- ldapauth (npm): affected all versions; no fix listed\n- ldapauth (npm): affected all versions; no fix listed\n- ldapauth-fork (npm): affected all versions; fixed in 2.3.3\n- ldapauth-fork (npm): affected all versions; fixed in 2.3.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2015-7294/ (Markdown: https://insights.sbomify.com/CVE-2015-7294/index.md)","id":"CVE-2015-7294","markdown":"https://insights.sbomify.com/CVE-2015-7294/index.md","name":"CVE-2015-7294","record":{"aliases":["GHSA-82mg-x548-gq3j"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass","data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js LDAP authentication library","requires_auth":"none","summary":"Remote attackers can perform LDAP injection via crafted usernames in the ldapauth-fork library, potentially bypassing authentication or accessing data.","user_interaction":"not_required","vuln_class":"other"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"ldapauth-fork","vendor":"ldapauth-fork_project"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-90","name":"Improper Neutralization of Special Elements used in an LDAP Query"}],"description":"ldapauth-fork before 2.3.3 allows remote attackers to perform LDAP injection attacks via a crafted username.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"LDAP Injection in ldapauth","id":"CVE-2015-7294","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"other","year":"2015"},"n_packages":4,"n_references":4,"next":{"headline":"Denial of service in n/a","id":"CVE-2015-7295"},"packages":[{"ecosystem":"npm","fixed":[],"introduced":["0"],"last_affected":[],"package":"ldapauth","purl":null,"source":"GHSA-82mg-x548-gq3j"},{"ecosystem":"npm","fixed":[],"introduced":["0"],"last_affected":[],"package":"ldapauth","purl":"pkg:npm/ldapauth","source":"GHSA-82mg-x548-gq3j"},{"ecosystem":"npm","fixed":["2.3.3"],"introduced":["0"],"last_affected":[],"package":"ldapauth-fork","purl":null,"source":"GHSA-82mg-x548-gq3j"},{"ecosystem":"npm","fixed":["2.3.3"],"introduced":["0"],"last_affected":[],"package":"ldapauth-fork","purl":"pkg:npm/ldapauth-fork","source":"GHSA-82mg-x548-gq3j"}],"prev":{"headline":"Plone vulnerable to cross-site request forgery","id":"CVE-2015-7293"},"products":["n/a"],"published":"2017-09-06","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote attackers can perform LDAP injection via crafted usernames in the ldapauth-fork library, potentially bypassing authentication or accessing data.","url":"https://insights.sbomify.com/CVE-2015-7294/"}