{"answers":{"affected":"2 open source packages ship an affected version, including gollum. It affects 1 product.","exploited":"There is no known exploitation of CVE-2015-7314 in the wild and no public exploit code.","fix":"Upgrade gollum to 4.0.1 or later.","what":"CVE-2015-7314 is a medium-severity path traversal vulnerability in n/a, published on 3 Oct 2015. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2015-7314 and fix it if it is affected.\n\nWhat it is: CVE-2015-7314 is a medium-severity path traversal vulnerability in n/a, published on 3 Oct 2015. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2015-7314 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- gollum (RubyGems): affected all versions; fixed in 4.0.1\n- gollum (RubyGems): affected all versions; fixed in 4.0.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2015-7314/ (Markdown: https://insights.sbomify.com/CVE-2015-7314/index.md)","id":"CVE-2015-7314","markdown":"https://insights.sbomify.com/CVE-2015-7314/index.md","name":"CVE-2015-7314","record":{"aliases":["GHSA-m2q3-53fq-7h66"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Ruby wiki library","requires_auth":"none","summary":"Remote attackers can read arbitrary files from the server due to a missing temporary-file check in the Precious module.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"gollum","vendor":"gollum_project"}],"cvss":{"score":4.3,"severity":"medium","source":"nvd","vector":"AV:N/AC:M/Au:N/C:P/I:N/A:N","version":"2.0"},"cwes":[{"id":"CWE-200","name":"Exposure of Sensitive Information to an Unauthorized Actor"}],"description":"The Precious module in gollum before 4.0.1 allows remote attackers to read arbitrary files by leveraging the lack of a certain temporary-file check.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Gollum Exposure of Sensitive Information","id":"CVE-2015-7314","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"path_traversal","year":"2015"},"n_packages":2,"n_references":5,"next":{"headline":"Plone unauthorized member addition vulnerability","id":"CVE-2015-7315"},"packages":[{"ecosystem":"RubyGems","fixed":["4.0.1"],"introduced":["0"],"last_affected":[],"package":"gollum","purl":null,"source":"GHSA-m2q3-53fq-7h66"},{"ecosystem":"RubyGems","fixed":["4.0.1"],"introduced":["0"],"last_affected":[],"package":"gollum","purl":"pkg:gem/gollum","source":"GHSA-m2q3-53fq-7h66"}],"prev":{"headline":"Denial of service in n/a","id":"CVE-2015-7313"},"products":["n/a"],"published":"2015-10-03","related":[{"cvss_score":8.8,"headline":"gollum and gollum-lib allow remote authenticated users to execute arbitrary code","id":"CVE-2014-9489","kev_date_added":null,"published":"2017-10-17"},{"cvss_score":6.1,"headline":"Gollum Cross-site Scripting vulnerability via filename parameter to New Page dialog","id":"CVE-2020-35305","kev_date_added":null,"published":"2022-07-15"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote attackers can read arbitrary files from the server due to a missing temporary-file check in the Precious module.","url":"https://insights.sbomify.com/CVE-2015-7314/"}