# CVE-2015-7318: Plone Header Injection

> Remote attackers can inject headers into HTTP responses in Plone, potentially leading to response splitting or cache poisoning.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Sep 2017
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-fq9r-8jpm-2222, PYSEC-2017-54

## What is CVE-2015-7318?

CVE-2015-7318 is a high-severity vulnerability in Plone Plone, published on 25 Sep 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Plone 3.3.0 through 3.3.6 allows remote attackers to inject headers into HTTP responses.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2015-7318?

3 open source packages ship an affected version, including plone and Plone. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `plone` | PyPI | From 3.3 | 4.0a1 |
| `plone` | PyPI | From 3.3 | 4.0a1 |
| `Plone` | PyPI | From 3.3 | 4.0a1 |

Products: Plone Plone.

## How do I fix CVE-2015-7318?

Upgrade plone to 4.0a1 or later.

## Is CVE-2015-7318 being exploited?

There is no known exploitation of CVE-2015-7318 in the wild and no public exploit code.

## Other vulnerabilities in Plone Plone

- [CVE-2021-33509](https://insights.sbomify.com/CVE-2021-33509/): Incorrect Permission Assignment for Critical Resource in Plone (critical 9.9)
- [CVE-2020-35190](https://insights.sbomify.com/CVE-2020-35190/): Hardcoded credentials in n/a (critical 9.8)
- [CVE-2020-7941](https://insights.sbomify.com/CVE-2020-7941/): Plone Unauthenticated Write Vulnerability (critical 9.8)
- [CVE-2011-3587](https://insights.sbomify.com/CVE-2011-3587/): Zope Command Execution Vulnerability (critical 9.3)
- [CVE-2021-33926](https://insights.sbomify.com/CVE-2021-33926/): Server-Side Request Forgery in Plone CMS (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2015-7318 and fix it if it is affected.

What it is: CVE-2015-7318 is a high-severity vulnerability in Plone Plone, published on 25 Sep 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2015-7318 in the wild and no public exploit code.

Affected packages and fixed versions:
- plone (PyPI): affected from 3.3; fixed in 4.0a1
- plone (PyPI): affected from 3.3; fixed in 4.0a1
- Plone (PyPI): affected from 3.3; fixed in 4.0a1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2015-7318/ (Markdown: https://insights.sbomify.com/CVE-2015-7318/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2015-7318
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2015-7318
- OSV: https://osv.dev/vulnerability/CVE-2015-7318

---
From sbomify Insights: https://insights.sbomify.com/CVE-2015-7318/
Summaries are generated and may contain mistakes; the official description above is the record.
