{"answers":{"affected":"6 open source packages ship an affected version, including ipython and notebook. It affects 2 products.","exploited":"There is no known exploitation of CVE-2015-7337 in the wild and no public exploit code.","fix":"Upgrade ipython to 3.2.2 or later.","what":"CVE-2015-7337 is a medium-severity cross-site scripting vulnerability in n/a, published on 29 Sep 2015. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2015-7337 and fix it if it is affected.\n\nWhat it is: CVE-2015-7337 is a medium-severity cross-site scripting vulnerability in n/a, published on 29 Sep 2015. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2015-7337 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- ipython (PyPI): affected all versions; fixed in 3.2.2\n- ipython (PyPI): affected all versions; fixed in 3.2.2\n- ipython (PyPI): affected all versions; fixed in 3.2.2\n- notebook (PyPI): affected from 4.0.0; fixed in 4.0.5\n- notebook (PyPI): affected from 4.0.0; fixed in 4.0.5\n- notebook (PyPI): affected from 4.0.0; fixed in 4.0.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2015-7337/ (Markdown: https://insights.sbomify.com/CVE-2015-7337/index.md)","id":"CVE-2015-7337","markdown":"https://insights.sbomify.com/CVE-2015-7337/index.md","name":"CVE-2015-7337","record":{"aliases":["GHSA-92mr-v722-f48m","PYSEC-2015-25","PYSEC-2015-27"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Jupyter Notebook","requires_auth":"none","summary":"Remote attackers can execute arbitrary JavaScript code in Jupyter Notebook via a crafted file, requiring user interaction to trigger the redirect.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"notebook","vendor":"ipython"},{"product":"notebook","vendor":"jupyter"}],"cvss":{"score":6.8,"severity":"medium","source":"nvd","vector":"AV:N/AC:M/Au:N/C:P/I:P/A:P","version":"2.0"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"}],"description":"The editor in IPython Notebook before 3.2.2 and Jupyter Notebook 4.0.x before 4.0.5 allows remote attackers to execute arbitrary JavaScript code via a crafted file, which triggers a redirect to files/, related to MIME types.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Improper Input Validation in Jupyter Notebook","id":"CVE-2015-7337","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"xss","year":"2015"},"n_packages":6,"n_references":7,"next":{"headline":"SQL injection in n/a","id":"CVE-2015-7338"},"packages":[{"ecosystem":"PyPI","fixed":["3.2.2"],"introduced":["0"],"last_affected":[],"package":"ipython","purl":null,"source":"GHSA-92mr-v722-f48m"},{"ecosystem":"PyPI","fixed":["3.2.2"],"introduced":["0"],"last_affected":[],"package":"ipython","purl":"pkg:pypi/ipython","source":"GHSA-92mr-v722-f48m"},{"ecosystem":"PyPI","fixed":["3.2.2"],"introduced":["0"],"last_affected":[],"package":"ipython","purl":"pkg:pypi/ipython","source":"PYSEC-2015-25"},{"ecosystem":"PyPI","fixed":["4.0.5"],"introduced":["4.0.0"],"last_affected":[],"package":"notebook","purl":null,"source":"GHSA-92mr-v722-f48m"},{"ecosystem":"PyPI","fixed":["4.0.5"],"introduced":["4.0.0"],"last_affected":[],"package":"notebook","purl":"pkg:pypi/notebook","source":"GHSA-92mr-v722-f48m"},{"ecosystem":"PyPI","fixed":["4.0.5"],"introduced":["4.0.0"],"last_affected":[],"package":"notebook","purl":"pkg:pypi/notebook","source":"PYSEC-2015-27"}],"prev":{"headline":"Security feature bypass in n/a","id":"CVE-2015-7336"},"products":["n/a"],"published":"2015-09-29","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote attackers can execute arbitrary JavaScript code in Jupyter Notebook via a crafted file, requiring user interaction to trigger the redirect.","url":"https://insights.sbomify.com/CVE-2015-7337/"}