CVE-2015-7503 Zend Framework Information Disclosure
Remote attackers can recover RSA private keys due to weak cryptography in the Zend Framework library, compromising encrypted data.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2015-7503?
CVE-2015-7503 is a high-severity vulnerability in n/a, published on 10 Oct 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Zend Framework before 2.4.9, zend-framework/zend-crypt 2.4.x before 2.4.9, and 2.5.x before 2.5.2 allows remote attackers to recover the RSA private key.
Weakness: CWE-320
Which versions are affected by CVE-2015-7503?
8 open source packages ship an affected version, including zendframework/zend-crypt and zendframework/zendframework. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
zendframework/zend-crypt Packagist | From 2.0.0 | 2.4.9 |
zendframework/zend-crypt Packagist | From 2.0.0 | 2.4.9 |
zendframework/zend-crypt Packagist | From 2.5.0 | 2.5.2 |
zendframework/zend-crypt Packagist | From 2.5.0 | 2.5.2 |
zendframework/zendframework Packagist | From 2.0.0 | 2.4.9 |
zendframework/zendframework Packagist | From 2.0.0 | 2.4.9 |
2 more packages
zendframework/zendframework Packagist | From 2.5.0 | 2.5.2 |
zendframework/zendframework Packagist | From 2.5.0 | 2.5.2 |
Products include Zend Zend Framework.
How do I fix CVE-2015-7503?
Upgrade zendframework/zend-crypt to a fixed version for your release line: 2.4.9 or 2.5.2.
Is CVE-2015-7503 being exploited?
There is no known exploitation of CVE-2015-7503 in the wild and no public exploit code.
Other vulnerabilities in n/a
Sources
Also known as GHSA-pm9m-w23q-5967, MGASA-2016-0196.