{"answers":{"affected":"8 open source packages ship an affected version, including zendframework/zend-crypt and zendframework/zendframework. It affects 1 product.","exploited":"There is no known exploitation of CVE-2015-7503 in the wild and no public exploit code.","fix":"Upgrade zendframework/zend-crypt to a fixed version for your release line: 2.4.9 or 2.5.2.","what":"CVE-2015-7503 is a high-severity vulnerability in n/a, published on 10 Oct 2017. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2015-7503 and fix it if it is affected.\n\nWhat it is: CVE-2015-7503 is a high-severity vulnerability in n/a, published on 10 Oct 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2015-7503 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- zendframework/zend-crypt (Packagist): affected from 2.0.0; fixed in 2.4.9\n- zendframework/zend-crypt (Packagist): affected from 2.0.0; fixed in 2.4.9\n- zendframework/zend-crypt (Packagist): affected from 2.5.0; fixed in 2.5.2\n- zendframework/zend-crypt (Packagist): affected from 2.5.0; fixed in 2.5.2\n- zendframework/zendframework (Packagist): affected from 2.0.0; fixed in 2.4.9\n- zendframework/zendframework (Packagist): affected from 2.0.0; fixed in 2.4.9\n- zendframework/zendframework (Packagist): affected from 2.5.0; fixed in 2.5.2\n- zendframework/zendframework (Packagist): affected from 2.5.0; fixed in 2.5.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2015-7503/ (Markdown: https://insights.sbomify.com/CVE-2015-7503/index.md)","id":"CVE-2015-7503","markdown":"https://insights.sbomify.com/CVE-2015-7503/index.md","name":"CVE-2015-7503","record":{"aliases":["GHSA-pm9m-w23q-5967","MGASA-2016-0196"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"PHP cryptography library","requires_auth":"none","summary":"Remote attackers can recover RSA private keys due to weak cryptography in the Zend Framework library, compromising encrypted data.","user_interaction":"not_required","vuln_class":"weak_cryptography"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"zend_framework","vendor":"zend"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N","version":"3.0"},"cwes":[{"id":"CWE-320","name":null}],"description":"Zend Framework before 2.4.9, zend-framework/zend-crypt 2.4.x before 2.4.9, and 2.5.x before 2.5.2 allows remote attackers to recover the RSA private key.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Zend Framework Information Disclosure","id":"CVE-2015-7503","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"weak_cryptography","year":"2015"},"n_packages":8,"n_references":2,"next":{"headline":"Memory corruption in n/a","id":"CVE-2015-7504"},"packages":[{"ecosystem":"Packagist","fixed":["2.4.9"],"introduced":["2.0.0"],"last_affected":[],"package":"zendframework/zend-crypt","purl":null,"source":"GHSA-pm9m-w23q-5967"},{"ecosystem":"Packagist","fixed":["2.4.9"],"introduced":["2.0.0"],"last_affected":[],"package":"zendframework/zend-crypt","purl":"pkg:composer/zendframework/zend-crypt","source":"GHSA-pm9m-w23q-5967"},{"ecosystem":"Packagist","fixed":["2.5.2"],"introduced":["2.5.0"],"last_affected":[],"package":"zendframework/zend-crypt","purl":null,"source":"GHSA-pm9m-w23q-5967"},{"ecosystem":"Packagist","fixed":["2.5.2"],"introduced":["2.5.0"],"last_affected":[],"package":"zendframework/zend-crypt","purl":"pkg:composer/zendframework/zend-crypt","source":"GHSA-pm9m-w23q-5967"},{"ecosystem":"Packagist","fixed":["2.4.9"],"introduced":["2.0.0"],"last_affected":[],"package":"zendframework/zendframework","purl":null,"source":"GHSA-pm9m-w23q-5967"},{"ecosystem":"Packagist","fixed":["2.4.9"],"introduced":["2.0.0"],"last_affected":[],"package":"zendframework/zendframework","purl":"pkg:composer/zendframework/zendframework","source":"GHSA-pm9m-w23q-5967"},{"ecosystem":"Packagist","fixed":["2.5.2"],"introduced":["2.5.0"],"last_affected":[],"package":"zendframework/zendframework","purl":null,"source":"GHSA-pm9m-w23q-5967"},{"ecosystem":"Packagist","fixed":["2.5.2"],"introduced":["2.5.0"],"last_affected":[],"package":"zendframework/zendframework","purl":"pkg:composer/zendframework/zendframework","source":"GHSA-pm9m-w23q-5967"}],"prev":{"headline":"Information disclosure in n/a","id":"CVE-2015-7502"},"products":["n/a"],"published":"2017-10-10","related":[{"cvss_score":9.8,"headline":"Deserialization in n/a","id":"CVE-2020-29312","kev_date_added":null,"published":"2023-04-04"},{"cvss_score":9.1,"headline":"Auth bypass in n/a","id":"CVE-2015-1555","kev_date_added":null,"published":"2017-08-07"},{"cvss_score":8.8,"headline":"Zend Framework CSRF Vulnerability","id":"CVE-2015-1786","kev_date_added":null,"published":"2017-06-08"},{"cvss_score":7.5,"headline":"Auth bypass in n/a","id":"CVE-2014-2685","kev_date_added":null,"published":"2014-09-04"},{"cvss_score":6.8,"headline":"ZendXml and Zend Framework contain XXE and XEE Vulnerabilities","id":"CVE-2015-5161","kev_date_added":null,"published":"2015-08-25"},{"cvss_score":6.8,"headline":"Several Zend Products Vulnerable to XXE and XEE attacks","id":"CVE-2014-2682","kev_date_added":null,"published":"2014-11-16"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote attackers can recover RSA private keys due to weak cryptography in the Zend Framework library, compromising encrypted data.","url":"https://insights.sbomify.com/CVE-2015-7503/"}