CVE-2015-7519 Phusion Passenger allows remote attackers to spoof headers
Attackers can spoof HTTP headers by using underscores instead of dashes in specific Phusion Passenger configurations, bypassing header filtering mechanisms.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2015-7519?
CVE-2015-7519 is a low-severity vulnerability in n/a, published on 8 Jan 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
agent/Core/Controller/SendRequest.cpp in Phusion Passenger before 4.0.60 and 5.0.x before 5.0.22, when used in Apache integration mode or in standalone mode without a filtering proxy, allows remote attackers to spoof headers passed to applications by using an _ (underscore) character instead of a - (dash) character in an HTTP header, as demonstrated by an X_User header.
Weakness: CWE-20
Which versions are affected by CVE-2015-7519?
4 open source packages ship an affected version, including passenger. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
passenger RubyGems | All versions | 4.0.60 |
passenger RubyGems | All versions | 4.0.60 |
passenger RubyGems | From 5.0.0 | 5.0.22 |
passenger RubyGems | From 5.0.0 | 5.0.22 |
Linux distribution packages (1)
rubygem-passenger SUSE:Linux Enterprise Module for Containers 12 | All versions | 5.0.18-6.1 |
Products include Phusionpassenger Phusion Passenger.
How do I fix CVE-2015-7519?
Upgrade passenger to a fixed version for your release line: 4.0.60 or 5.0.22.
Is CVE-2015-7519 being exploited?
There is no known exploitation of CVE-2015-7519 in the wild and no public exploit code.
Sources
Also known as DEBIAN-CVE-2015-7519, DLA-394-1, GHSA-fxwv-953p-7qpf, SUSE-SU-2015:2337-1.