# CVE-2015-7519: Phusion Passenger allows remote attackers to spoof headers

> Attackers can spoof HTTP headers by using underscores instead of dashes in specific Phusion Passenger configurations, bypassing header filtering mechanisms.

- **Severity:** Low 3.7 (`CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Jan 2016
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2015-7519, DLA-394-1, GHSA-fxwv-953p-7qpf, SUSE-SU-2015:2337-1

## What is CVE-2015-7519?

CVE-2015-7519 is a low-severity vulnerability in n/a, published on 8 Jan 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

agent/Core/Controller/SendRequest.cpp in Phusion Passenger before 4.0.60 and 5.0.x before 5.0.22, when used in Apache integration mode or in standalone mode without a filtering proxy, allows remote attackers to spoof headers passed to applications by using an _ (underscore) character instead of a - (dash) character in an HTTP header, as demonstrated by an X_User header.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2015-7519?

4 open source packages ship an affected version, including passenger. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `passenger` | RubyGems | All versions | 4.0.60 |
| `passenger` | RubyGems | All versions | 4.0.60 |
| `passenger` | RubyGems | From 5.0.0 | 5.0.22 |
| `passenger` | RubyGems | From 5.0.0 | 5.0.22 |
| `rubygem-passenger` | SUSE:Linux Enterprise Module for Containers 12 | All versions | 5.0.18-6.1 |

Products: Phusionpassenger Phusion Passenger.

## How do I fix CVE-2015-7519?

Upgrade passenger to a fixed version for your release line: 4.0.60 or 5.0.22.

## Is CVE-2015-7519 being exploited?

There is no known exploitation of CVE-2015-7519 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2015-7519 and fix it if it is affected.

What it is: CVE-2015-7519 is a low-severity vulnerability in n/a, published on 8 Jan 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2015-7519 in the wild and no public exploit code.

Affected packages and fixed versions:
- passenger (RubyGems): affected all versions; fixed in 4.0.60
- passenger (RubyGems): affected all versions; fixed in 4.0.60
- passenger (RubyGems): affected from 5.0.0; fixed in 5.0.22
- passenger (RubyGems): affected from 5.0.0; fixed in 5.0.22

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2015-7519/ (Markdown: https://insights.sbomify.com/CVE-2015-7519/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2015-7519
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2015-7519
- OSV: https://osv.dev/vulnerability/CVE-2015-7519

---
From sbomify Insights: https://insights.sbomify.com/CVE-2015-7519/
Summaries are generated and may contain mistakes; the official description above is the record.
