# CVE-2015-7528: Information Exposure in Kubernetes

> Remote attackers can read arbitrary pod logs in Kubernetes by manipulating the container name, exposing sensitive data.

- **Severity:** Medium 5.3 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Apr 2016
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-mqf3-28j7-3mj6, GO-2022-0857, RHSA-2015:2544

## What is CVE-2015-7528?

CVE-2015-7528 is a medium-severity vulnerability in Kubernetes Kubernetes, published on 11 Apr 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Kubernetes before 1.2.0-alpha.5 allows remote attackers to read arbitrary pod logs via a container name.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2015-7528?

3 open source packages ship an affected version, including github.com/kubernetes/kubernetes. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/kubernetes/kubernetes` | Go | All versions | 1.2.0 |
| `github.com/kubernetes/kubernetes` | Go | All versions | 1.2.0 |
| `github.com/kubernetes/kubernetes` | Go | All versions | 1.2.0 |
| `openshift` | Red Hat:openshift:3.0::el7 | All versions | 0:3.0.2.0-0.git.38.7576bc5.el7ose |
| `openshift-clients` | Red Hat:openshift:3.0::el7 | All versions | 0:3.0.2.0-0.git.38.7576bc5.el7ose |
| `openshift-master` | Red Hat:openshift:3.0::el7 | All versions | 0:3.0.2.0-0.git.38.7576bc5.el7ose |
| `openshift-node` | Red Hat:openshift:3.0::el7 | All versions | 0:3.0.2.0-0.git.38.7576bc5.el7ose |
| `openshift-sdn-ovs` | Red Hat:openshift:3.0::el7 | All versions | 0:3.0.2.0-0.git.38.7576bc5.el7ose |
| `tuned-profiles-openshift-node` | Red Hat:openshift:3.0::el7 | All versions | 0:3.0.2.0-0.git.38.7576bc5.el7ose |
| `atomic-openshift` | Red Hat:openshift:3.1::el7 | All versions | 0:3.1.0.4-1.git.15.5e061c3.el7aos |
| `atomic-openshift-clients` | Red Hat:openshift:3.1::el7 | All versions | 0:3.1.0.4-1.git.15.5e061c3.el7aos |
| `atomic-openshift-clients-redistributable` | Red Hat:openshift:3.1::el7 | All versions | 0:3.1.0.4-1.git.15.5e061c3.el7aos |
| `atomic-openshift-dockerregistry` | Red Hat:openshift:3.1::el7 | All versions | 0:3.1.0.4-1.git.15.5e061c3.el7aos |
| `atomic-openshift-master` | Red Hat:openshift:3.1::el7 | All versions | 0:3.1.0.4-1.git.15.5e061c3.el7aos |
| `atomic-openshift-node` | Red Hat:openshift:3.1::el7 | All versions | 0:3.1.0.4-1.git.15.5e061c3.el7aos |
| `atomic-openshift-pod` | Red Hat:openshift:3.1::el7 | All versions | 0:3.1.0.4-1.git.15.5e061c3.el7aos |
| `atomic-openshift-recycle` | Red Hat:openshift:3.1::el7 | All versions | 0:3.1.0.4-1.git.15.5e061c3.el7aos |
| `atomic-openshift-sdn-ovs` | Red Hat:openshift:3.1::el7 | All versions | 0:3.1.0.4-1.git.15.5e061c3.el7aos |
| `tuned-profiles-atomic-openshift-node` | Red Hat:openshift:3.1::el7 | All versions | 0:3.1.0.4-1.git.15.5e061c3.el7aos |

Products: Kubernetes Kubernetes, Redhat Openshift.

## How do I fix CVE-2015-7528?

Upgrade github.com/kubernetes/kubernetes to 1.2.0 or later.

## Is CVE-2015-7528 being exploited?

There is no known exploitation of CVE-2015-7528 in the wild and no public exploit code.

## Other vulnerabilities in Kubernetes Kubernetes

- [CVE-2018-1002105](https://insights.sbomify.com/CVE-2018-1002105/): Privilege Escalation in Kubernetes (critical 9.8)
- [CVE-2017-1000056](https://insights.sbomify.com/CVE-2017-1000056/): Kubernetes Privilege Escalation (critical 9.8)
- [CVE-2016-1906](https://insights.sbomify.com/CVE-2016-1906/): Authorization bypass in Openshift (critical 9.8)
- [CVE-2023-3676](https://insights.sbomify.com/CVE-2023-3676/): Kubernetes - Windows nodes - Insufficient input sanitization leads to privilege escalation (high 8.8)
- [CVE-2023-3955](https://insights.sbomify.com/CVE-2023-3955/): Kubernetes - Windows nodes - Insufficient input sanitization leads to privilege escalation (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2015-7528 and fix it if it is affected.

What it is: CVE-2015-7528 is a medium-severity vulnerability in Kubernetes Kubernetes, published on 11 Apr 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2015-7528 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/kubernetes/kubernetes (Go): affected all versions; fixed in 1.2.0
- github.com/kubernetes/kubernetes (Go): affected all versions; fixed in 1.2.0
- github.com/kubernetes/kubernetes (Go): affected all versions; fixed in 1.2.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2015-7528/ (Markdown: https://insights.sbomify.com/CVE-2015-7528/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2015-7528
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2015-7528
- OSV: https://osv.dev/vulnerability/CVE-2015-7528

---
From sbomify Insights: https://insights.sbomify.com/CVE-2015-7528/
Summaries are generated and may contain mistakes; the official description above is the record.
