# CVE-2015-7529: SoSReport Predictable Tmp File Names

> Local attackers can exploit symlink attacks in temporary directories to read sensitive data or escalate privileges using the sosreport utility.

- **Severity:** High 7.8 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Nov 2017
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2015-7529, GHSA-3g56-2hh3-35ph, PYSEC-2017-73, RHSA-2016:0152, RHSA-2016:0188, UBUNTU-CVE-2015-7529

## What is CVE-2015-7529?

CVE-2015-7529 is a high-severity path traversal vulnerability in Canonical Ubuntu Linux, published on 6 Nov 2017. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

sosreport in SoS 3.x allows local users to obtain sensitive information from sosreport files or gain privileges via a symlink attack on an archive file in a temporary directory, as demonstrated by sosreport-$hostname-$date.tar in /tmp/sosreport-$hostname-$date.

Weakness: CWE-59 (Improper Link Resolution Before File Access)

## Which versions are affected by CVE-2015-7529?

3 open source packages ship an affected version, including sosreport. It affects 8 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `sosreport` | PyPI | From 3.0 | None |
| `sosreport` | PyPI | From 3.0 | 3.3 |
| `sosreport` | PyPI | From 3.0 | 3.3 |
| `sos` | Red Hat:enterprise_linux:6::client | All versions | 0:3.2-28.el6_7.2 |
| `sos` | Red Hat:enterprise_linux:6::computenode | All versions | 0:3.2-28.el6_7.2 |
| `sos` | Red Hat:enterprise_linux:6::server | All versions | 0:3.2-28.el6_7.2 |
| `sos` | Red Hat:enterprise_linux:6::workstation | All versions | 0:3.2-28.el6_7.2 |
| `sos` | Red Hat:enterprise_linux:7::client | All versions | 0:3.2-35.el7_2.3 |
| `sos` | Red Hat:enterprise_linux:7::computenode | All versions | 0:3.2-35.el7_2.3 |
| `sos` | Red Hat:enterprise_linux:7::server | All versions | 0:3.2-35.el7_2.3 |
| `sos` | Red Hat:enterprise_linux:7::workstation | All versions | 0:3.2-35.el7_2.3 |

Products: Canonical Ubuntu Linux, Redhat Enterprise Linux Desktop, Redhat Enterprise Linux Server, Redhat Enterprise Linux Server Aus, Redhat Enterprise Linux Server Eus, Redhat Enterprise Linux Server Tus, Redhat Enterprise Linux Workstation, Sos Project Sos.

## How do I fix CVE-2015-7529?

Upgrade sosreport to 3.3 or later.

## Is CVE-2015-7529 being exploited?

There is no known exploitation of CVE-2015-7529 in the wild and no public exploit code.

## Other vulnerabilities in Canonical Ubuntu Linux

- [CVE-2020-11651](https://insights.sbomify.com/CVE-2020-11651/): SaltStack Salt Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2020-7247](https://insights.sbomify.com/CVE-2020-7247/): OpenSMTPD Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2019-16928](https://insights.sbomify.com/CVE-2019-16928/): Exim Out-of-bounds Write (critical 9.8, exploited in the wild)
- [CVE-2018-6789](https://insights.sbomify.com/CVE-2018-6789/): Exim Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2015-2590](https://insights.sbomify.com/CVE-2015-2590/): Oracle Java SE and Java SE Embedded Remote Code Execution (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2015-7529 and fix it if it is affected.

What it is: CVE-2015-7529 is a high-severity path traversal vulnerability in Canonical Ubuntu Linux, published on 6 Nov 2017. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2015-7529 in the wild and no public exploit code.

Affected packages and fixed versions:
- sosreport (PyPI): affected from 3.0; no fix listed
- sosreport (PyPI): affected from 3.0; fixed in 3.3
- sosreport (PyPI): affected from 3.0; fixed in 3.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2015-7529/ (Markdown: https://insights.sbomify.com/CVE-2015-7529/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2015-7529
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2015-7529
- OSV: https://osv.dev/vulnerability/CVE-2015-7529

---
From sbomify Insights: https://insights.sbomify.com/CVE-2015-7529/
Summaries are generated and may contain mistakes; the official description above is the record.
