CVE-2015-7537 Jenkins Vulnerable to Cross-Site Request Forgery (CSRF) Attack

High 8.8 Published Updated

Remote attackers can hijack administrator sessions via CSRF, potentially leading to unauthorized actions on the Jenkins server.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2015-7537?

CVE-2015-7537 is a high-severity vulnerability in Jenkins Jenkins, published on 3 Feb 2016. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

Cross-site request forgery (CSRF) vulnerability in Jenkins before 1.640 and LTS before 1.625.2 allows remote attackers to hijack the authentication of administrators for requests that have unspecified impact via vectors related to the HTTP GET method.

Weakness: CWE-352

Which versions are affected by CVE-2015-7537?

4 open source packages ship an affected version, including org.jenkins-ci.main:jenkins-core. It affects 2 products.

PackageAffectedFixed in
org.jenkins-ci.main:jenkins-core MavenAll versions1.625.2
org.jenkins-ci.main:jenkins-core MavenAll versions1.625.2
org.jenkins-ci.main:jenkins-core MavenFrom 1.6261.640
org.jenkins-ci.main:jenkins-core MavenFrom 1.6261.640

Products include Jenkins Jenkins, Redhat Openshift.

How do I fix CVE-2015-7537?

Upgrade org.jenkins-ci.main:jenkins-core to a fixed version for your release line: 1.625.2 or 1.640.

Is CVE-2015-7537 being exploited?

There is no known exploitation of CVE-2015-7537 in the wild and no public exploit code.

All Jenkins Jenkins vulnerabilities

Sources

Also known as GHSA-3vhr-f5xr-8vpx.

Is CVE-2015-7537 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free