CVE-2015-7538 Jenkins Vulnerable to Cross-Site Request Forgery (CSRF) Attack
Remote attackers can bypass CSRF protection in Jenkins, potentially allowing unauthorized actions on behalf of authenticated users.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2015-7538?
CVE-2015-7538 is a high-severity vulnerability in Jenkins Jenkins, published on 3 Feb 2016. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
Jenkins before 1.640 and LTS before 1.625.2 allow remote attackers to bypass the CSRF protection mechanism via unspecified vectors.
Which versions are affected by CVE-2015-7538?
4 open source packages ship an affected version, including org.jenkins-ci.main:jenkins-core. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
org.jenkins-ci.main:jenkins-core Maven | All versions | 1.625.2 |
org.jenkins-ci.main:jenkins-core Maven | All versions | 1.625.2 |
org.jenkins-ci.main:jenkins-core Maven | From 1.626 | 1.640 |
org.jenkins-ci.main:jenkins-core Maven | From 1.626 | 1.640 |
Products include Jenkins Jenkins, Redhat Openshift.
How do I fix CVE-2015-7538?
Upgrade org.jenkins-ci.main:jenkins-core to a fixed version for your release line: 1.625.2 or 1.640.
Is CVE-2015-7538 being exploited?
There is no known exploitation of CVE-2015-7538 in the wild and no public exploit code.
Other vulnerabilities in Jenkins Jenkins
- CVE-2024-23897 Jenkins Command Line Interface (CLI) Path Traversal
- CVE-2018-1000861 Jenkins Stapler Web Framework Deserialization of Untrusted Data
- CVE-2017-1000353 Jenkins Remote Code Execution
- CVE-2015-5317 Jenkins User Interface (UI) Information Disclosure
- CVE-2021-21690 Multiple vulnerabilities allow bypassing path filtering of agent-to-controller access control in Jenkins
Sources
Also known as GHSA-w7qm-fprw-cqgq.