CVE-2015-7539 Jenkins does not Verify Checksums for Plugin Files
Man-in-the-middle attackers can execute arbitrary code by exploiting missing checksum verification in the Jenkins Plugins Manager.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2015-7539?
CVE-2015-7539 is a high-severity code injection vulnerability in Jenkins Jenkins, published on 3 Feb 2016. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
The Plugins Manager in Jenkins before 1.640 and LTS before 1.625.2 does not verify checksums for plugin files referenced in update site data, which makes it easier for man-in-the-middle attackers to execute arbitrary code via a crafted plugin.
Weakness: CWE-345
Which versions are affected by CVE-2015-7539?
4 open source packages ship an affected version, including org.jenkins-ci.main:jenkins-core. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
org.jenkins-ci.main:jenkins-core Maven | All versions | 1.625.2 |
org.jenkins-ci.main:jenkins-core Maven | All versions | 1.625.2 |
org.jenkins-ci.main:jenkins-core Maven | From 1.626 | 1.640 |
org.jenkins-ci.main:jenkins-core Maven | From 1.626 | 1.640 |
Products include Jenkins Jenkins, Redhat Openshift.
How do I fix CVE-2015-7539?
Upgrade org.jenkins-ci.main:jenkins-core to a fixed version for your release line: 1.625.2 or 1.640.
Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.
Is CVE-2015-7539 being exploited?
There is no known exploitation of CVE-2015-7539 in the wild and no public exploit code.
Other vulnerabilities in Jenkins Jenkins
- CVE-2024-23897 Jenkins Command Line Interface (CLI) Path Traversal
- CVE-2018-1000861 Jenkins Stapler Web Framework Deserialization of Untrusted Data
- CVE-2017-1000353 Jenkins Remote Code Execution
- CVE-2015-5317 Jenkins User Interface (UI) Information Disclosure
- CVE-2021-21690 Multiple vulnerabilities allow bypassing path filtering of agent-to-controller access control in Jenkins
Sources
Also known as GHSA-x274-9m9r-fm5g.