# CVE-2015-7539: Jenkins does not Verify Checksums for Plugin Files

> Man-in-the-middle attackers can execute arbitrary code by exploiting missing checksum verification in the Jenkins Plugins Manager.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 3 Feb 2016
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-x274-9m9r-fm5g

## What is CVE-2015-7539?

CVE-2015-7539 is a high-severity code injection vulnerability in Jenkins Jenkins, published on 3 Feb 2016. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

The Plugins Manager in Jenkins before 1.640 and LTS before 1.625.2 does not verify checksums for plugin files referenced in update site data, which makes it easier for man-in-the-middle attackers to execute arbitrary code via a crafted plugin.

Weakness: CWE-345 (Insufficient Verification of Data Authenticity)

## Which versions are affected by CVE-2015-7539?

4 open source packages ship an affected version, including org.jenkins-ci.main:jenkins-core. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.main:jenkins-core` | Maven | All versions | 1.625.2 |
| `org.jenkins-ci.main:jenkins-core` | Maven | All versions | 1.625.2 |
| `org.jenkins-ci.main:jenkins-core` | Maven | From 1.626 | 1.640 |
| `org.jenkins-ci.main:jenkins-core` | Maven | From 1.626 | 1.640 |

Products: Jenkins Jenkins, Redhat Openshift.

## How do I fix CVE-2015-7539?

Upgrade org.jenkins-ci.main:jenkins-core to a fixed version for your release line: 1.625.2 or 1.640.

## Is CVE-2015-7539 being exploited?

There is no known exploitation of CVE-2015-7539 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins Jenkins

- [CVE-2024-23897](https://insights.sbomify.com/CVE-2024-23897/): Jenkins Command Line Interface (CLI) Path Traversal (critical 9.8, exploited in the wild)
- [CVE-2018-1000861](https://insights.sbomify.com/CVE-2018-1000861/): Jenkins Stapler Web Framework Deserialization of Untrusted Data (critical 9.8, exploited in the wild)
- [CVE-2017-1000353](https://insights.sbomify.com/CVE-2017-1000353/): Jenkins Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2015-5317](https://insights.sbomify.com/CVE-2015-5317/): Jenkins User Interface (UI) Information Disclosure (high 7.5, exploited in the wild)
- [CVE-2021-21690](https://insights.sbomify.com/CVE-2021-21690/): Multiple vulnerabilities allow bypassing path filtering of agent-to-controller access control in Jenkins (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2015-7539 and fix it if it is affected.

What it is: CVE-2015-7539 is a high-severity code injection vulnerability in Jenkins Jenkins, published on 3 Feb 2016. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2015-7539 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.main:jenkins-core (Maven): affected all versions; fixed in 1.625.2
- org.jenkins-ci.main:jenkins-core (Maven): affected all versions; fixed in 1.625.2
- org.jenkins-ci.main:jenkins-core (Maven): affected from 1.626; fixed in 1.640
- org.jenkins-ci.main:jenkins-core (Maven): affected from 1.626; fixed in 1.640

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2015-7539/ (Markdown: https://insights.sbomify.com/CVE-2015-7539/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2015-7539
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2015-7539
- OSV: https://osv.dev/vulnerability/CVE-2015-7539

---
From sbomify Insights: https://insights.sbomify.com/CVE-2015-7539/
Summaries are generated and may contain mistakes; the official description above is the record.
