{"answers":{"affected":"2 open source packages ship an affected version, including colorscore. It affects 1 product.","exploited":"There is no known exploitation of CVE-2015-7541 in the wild and no public exploit code.","fix":"Upgrade colorscore to 0.0.5 or later.","what":"CVE-2015-7541 is a critical command injection vulnerability in n/a, published on 8 Jan 2016. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2015-7541 and fix it if it is affected.\n\nWhat it is: CVE-2015-7541 is a critical command injection vulnerability in n/a, published on 8 Jan 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2015-7541 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- colorscore (RubyGems): affected all versions; fixed in 0.0.5\n- colorscore (RubyGems): affected all versions; fixed in 0.0.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2015-7541/ (Markdown: https://insights.sbomify.com/CVE-2015-7541/index.md)","id":"CVE-2015-7541","markdown":"https://insights.sbomify.com/CVE-2015-7541/index.md","name":"CVE-2015-7541","record":{"aliases":["GHSA-73qw-ww62-m54x"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Ruby colorscore gem","requires_auth":"none","summary":"Attackers can execute arbitrary code via shell metacharacters in image path, colors, or depth variables in the colorscore Ruby gem.","user_interaction":"not_required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"colorscore","vendor":"colorscore_project"}],"cvss":{"score":10,"severity":"critical","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-77","name":"Improper Neutralization of Special Elements used in a Command"}],"description":"The initialize method in the Histogram class in lib/colorscore/histogram.rb in the colorscore gem before 0.0.5 for Ruby allows context-dependent attackers to execute arbitrary code via shell metacharacters in the (1) image_path, (2) colors, or (3) depth variable.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"colorscore Command Injection vulnerability","id":"CVE-2015-7541","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"command_injection","year":"2015"},"n_packages":2,"n_references":3,"next":{"headline":"Weak cryptography in libgwenhywfar","id":"CVE-2015-7542"},"packages":[{"ecosystem":"RubyGems","fixed":["0.0.5"],"introduced":["0"],"last_affected":[],"package":"colorscore","purl":null,"source":"GHSA-73qw-ww62-m54x"},{"ecosystem":"RubyGems","fixed":["0.0.5"],"introduced":["0"],"last_affected":[],"package":"colorscore","purl":"pkg:gem/colorscore","source":"GHSA-73qw-ww62-m54x"}],"prev":{"headline":"Denial of service in n/a","id":"CVE-2015-7540"},"products":["n/a"],"published":"2016-01-08","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Attackers can execute arbitrary code via shell metacharacters in image path, colors, or depth variables in the colorscore Ruby gem.","url":"https://insights.sbomify.com/CVE-2015-7541/"}