# CVE-2015-7541: colorscore Command Injection vulnerability

> Attackers can execute arbitrary code via shell metacharacters in image path, colors, or depth variables in the colorscore Ruby gem.

- **Severity:** Critical 10.0 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Jan 2016
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-73qw-ww62-m54x

## What is CVE-2015-7541?

CVE-2015-7541 is a critical command injection vulnerability in n/a, published on 8 Jan 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The initialize method in the Histogram class in lib/colorscore/histogram.rb in the colorscore gem before 0.0.5 for Ruby allows context-dependent attackers to execute arbitrary code via shell metacharacters in the (1) image_path, (2) colors, or (3) depth variable.

Weakness: CWE-77 (Improper Neutralization of Special Elements used in a Command)

## Which versions are affected by CVE-2015-7541?

2 open source packages ship an affected version, including colorscore. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `colorscore` | RubyGems | All versions | 0.0.5 |
| `colorscore` | RubyGems | All versions | 0.0.5 |

Products: Colorscore Project Colorscore.

## How do I fix CVE-2015-7541?

Upgrade colorscore to 0.0.5 or later.

## Is CVE-2015-7541 being exploited?

There is no known exploitation of CVE-2015-7541 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2015-7541 and fix it if it is affected.

What it is: CVE-2015-7541 is a critical command injection vulnerability in n/a, published on 8 Jan 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2015-7541 in the wild and no public exploit code.

Affected packages and fixed versions:
- colorscore (RubyGems): affected all versions; fixed in 0.0.5
- colorscore (RubyGems): affected all versions; fixed in 0.0.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2015-7541/ (Markdown: https://insights.sbomify.com/CVE-2015-7541/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2015-7541
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2015-7541
- OSV: https://osv.dev/vulnerability/CVE-2015-7541

---
From sbomify Insights: https://insights.sbomify.com/CVE-2015-7541/
Summaries are generated and may contain mistakes; the official description above is the record.
