CVE-2015-7546 OpenStack Identity Keystone and keystonemiddleware Insufficiently Protected Credentials
Authenticated users can bypass access restrictions and access cloud resources by manipulating revoked PKI tokens in OpenStack Identity.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2015-7546?
CVE-2015-7546 is a high-severity authentication bypass vulnerability in Oracle Solaris, published on 3 Feb 2016. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
The identity service in OpenStack Identity (Keystone) before 2015.1.3 (Kilo) and 8.0.x before 8.0.2 (Liberty) and keystonemiddleware (formerly python-keystoneclient) before 1.5.4 (Kilo) and Liberty before 2.3.3 does not properly invalidate authorization tokens when using the PKI or PKIZ token providers, which allows remote authenticated users to bypass intended access restrictions and gain access to cloud resources by manipulating byte fields within a revoked token.
Weakness: CWE-522
Which versions are affected by CVE-2015-7546?
12 open source packages ship an affected version, including keystonemiddleware and keystone. It affects 3 products.
| Package | Affected | Fixed in |
|---|---|---|
keystonemiddleware PyPI | All versions | 1.5.4, 2.3.3 |
keystonemiddleware PyPI | All versions | 1.5.4 |
keystonemiddleware PyPI | All versions | 1.5.4 |
keystonemiddleware PyPI | From 1.6.0 | 2.3.3 |
keystonemiddleware PyPI | From 1.6.0 | 2.3.3 |
keystonemiddleware PyPI | From 2.4.0 | 4.1.0 |
6 more packages
keystonemiddleware PyPI | From 2.4.0 | 4.1.0 |
keystone PyPI | From 8.0 | 8.1.0, 9.0.0.0b2 |
keystone PyPI | From 8.0 | 8.1.0 |
keystone PyPI | From 8.0 | 8.1.0 |
keystone PyPI | From 9.0.0.0b1 | 9.0.0.0b2 |
keystone PyPI | From 9.0.0.0b1 | 9.0.0.0b2 |
Products include Openstack Keystone, Openstack Keystonemiddleware, Oracle Solaris.
How do I fix CVE-2015-7546?
Upgrade keystonemiddleware to a fixed version for your release line: 1.5.4, 2.3.3 or 4.1.0.
Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.
Is CVE-2015-7546 being exploited?
There is no known exploitation of CVE-2015-7546 in the wild and no public exploit code.
Other vulnerabilities in Oracle Solaris
- CVE-2020-12690 Insufficient Session Expiration in OpenStack Keystone
- CVE-2019-19687 OpenStack Keystone Credential Leakage
- CVE-2026-43001 OpenStack Keystone has an Incorrect Authorization Issue
- CVE-2014-2828 OpenStack Identity (Keystone) DoS through V3 API authentication chaining
- CVE-2021-38155 OpenStack Keystone allows information disclosure during account locking
Sources
Also known as DEBIAN-CVE-2015-7546, GHSA-8c4w-v65p-jvcv, PYSEC-2016-20, PYSEC-2026-2549.