# CVE-2015-7546: OpenStack Identity Keystone and keystonemiddleware Insufficiently Protected Credentials

> Authenticated users can bypass access restrictions and access cloud resources by manipulating revoked PKI tokens in OpenStack Identity.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Feb 2016
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2015-7546, GHSA-8c4w-v65p-jvcv, PYSEC-2016-20, PYSEC-2026-2549

## What is CVE-2015-7546?

CVE-2015-7546 is a high-severity authentication bypass vulnerability in Oracle Solaris, published on 3 Feb 2016. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

The identity service in OpenStack Identity (Keystone) before 2015.1.3 (Kilo) and 8.0.x before 8.0.2 (Liberty) and keystonemiddleware (formerly python-keystoneclient) before 1.5.4 (Kilo) and Liberty before 2.3.3 does not properly invalidate authorization tokens when using the PKI or PKIZ token providers, which allows remote authenticated users to bypass intended access restrictions and gain access to cloud resources by manipulating byte fields within a revoked token.

Weakness: CWE-522 (Insufficiently Protected Credentials)

## Which versions are affected by CVE-2015-7546?

12 open source packages ship an affected version, including keystonemiddleware and keystone. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `keystonemiddleware` | PyPI | All versions | 1.5.4, 2.3.3 |
| `keystonemiddleware` | PyPI | All versions | 1.5.4 |
| `keystonemiddleware` | PyPI | All versions | 1.5.4 |
| `keystonemiddleware` | PyPI | From 1.6.0 | 2.3.3 |
| `keystonemiddleware` | PyPI | From 1.6.0 | 2.3.3 |
| `keystonemiddleware` | PyPI | From 2.4.0 | 4.1.0 |
| `keystonemiddleware` | PyPI | From 2.4.0 | 4.1.0 |
| `keystone` | PyPI | From 8.0 | 8.1.0, 9.0.0.0b2 |
| `keystone` | PyPI | From 8.0 | 8.1.0 |
| `keystone` | PyPI | From 8.0 | 8.1.0 |
| `keystone` | PyPI | From 9.0.0.0b1 | 9.0.0.0b2 |
| `keystone` | PyPI | From 9.0.0.0b1 | 9.0.0.0b2 |

Products: Openstack Keystone, Openstack Keystonemiddleware, Oracle Solaris.

## How do I fix CVE-2015-7546?

Upgrade keystonemiddleware to a fixed version for your release line: 1.5.4, 2.3.3 or 4.1.0.

## Is CVE-2015-7546 being exploited?

There is no known exploitation of CVE-2015-7546 in the wild and no public exploit code.

## Other vulnerabilities in Oracle Solaris

- [CVE-2020-12690](https://insights.sbomify.com/CVE-2020-12690/): Insufficient Session Expiration in OpenStack Keystone (high 8.8)
- [CVE-2019-19687](https://insights.sbomify.com/CVE-2019-19687/): OpenStack Keystone Credential Leakage (high 8.8)
- [CVE-2026-43001](https://insights.sbomify.com/CVE-2026-43001/): OpenStack Keystone has an Incorrect Authorization Issue (high 7.9)
- [CVE-2014-2828](https://insights.sbomify.com/CVE-2014-2828/): OpenStack Identity (Keystone) DoS through V3 API authentication chaining (high 7.8)
- [CVE-2021-38155](https://insights.sbomify.com/CVE-2021-38155/): OpenStack Keystone allows information disclosure during account locking (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2015-7546 and fix it if it is affected.

What it is: CVE-2015-7546 is a high-severity authentication bypass vulnerability in Oracle Solaris, published on 3 Feb 2016. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2015-7546 in the wild and no public exploit code.

Affected packages and fixed versions:
- keystonemiddleware (PyPI): affected all versions; fixed in 1.5.4, 2.3.3
- keystonemiddleware (PyPI): affected all versions; fixed in 1.5.4
- keystonemiddleware (PyPI): affected all versions; fixed in 1.5.4
- keystonemiddleware (PyPI): affected from 1.6.0; fixed in 2.3.3
- keystonemiddleware (PyPI): affected from 1.6.0; fixed in 2.3.3
- keystonemiddleware (PyPI): affected from 2.4.0; fixed in 4.1.0
- keystonemiddleware (PyPI): affected from 2.4.0; fixed in 4.1.0
- keystone (PyPI): affected from 8.0; fixed in 8.1.0, 9.0.0.0b2
- keystone (PyPI): affected from 8.0; fixed in 8.1.0
- keystone (PyPI): affected from 8.0; fixed in 8.1.0
- keystone (PyPI): affected from 9.0.0.0b1; fixed in 9.0.0.0b2
- keystone (PyPI): affected from 9.0.0.0b1; fixed in 9.0.0.0b2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2015-7546/ (Markdown: https://insights.sbomify.com/CVE-2015-7546/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2015-7546
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2015-7546
- OSV: https://osv.dev/vulnerability/CVE-2015-7546

---
From sbomify Insights: https://insights.sbomify.com/CVE-2015-7546/
Summaries are generated and may contain mistakes; the official description above is the record.
