{"answers":{"affected":"2 open source packages ship an affected version, including org.apache.activemq:activemq-client. It affects 3 products.","exploited":"There is no known exploitation of CVE-2015-7559 in the wild and no public exploit code.","fix":"Upgrade org.apache.activemq:activemq-client to 5.14.5 or later.","what":"CVE-2015-7559 is a low-severity missing authorization vulnerability in Apache Activemq, published on 1 Aug 2019. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2015-7559 and fix it if it is affected.\n\nWhat it is: CVE-2015-7559 is a low-severity missing authorization vulnerability in Apache Activemq, published on 1 Aug 2019. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2015-7559 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.apache.activemq:activemq-client (Maven): affected all versions; fixed in 5.14.5\n- org.apache.activemq:activemq-client (Maven): affected all versions; fixed in 5.14.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2015-7559/ (Markdown: https://insights.sbomify.com/CVE-2015-7559/index.md)","id":"CVE-2015-7559","markdown":"https://insights.sbomify.com/CVE-2015-7559/index.md","name":"CVE-2015-7559","record":{"aliases":["DEBIAN-CVE-2015-7559","DLA-913-1","GHSA-jvpp-hxjj-5ccc","UBUNTU-CVE-2015-7559"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Apache ActiveMQ","requires_auth":"high_privilege","summary":"An attacker with broker access can trigger a remote shutdown command, causing denial of service on connected ActiveMQ clients.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"activemq","vendor":"apache"},{"product":"jboss_a-mq","vendor":"redhat"},{"product":"jboss_fuse","vendor":"redhat"}],"cvss":{"score":2.7,"severity":"low","source":"cna","vector":"CVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:N/A:L","version":"3.0"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"},{"id":"CWE-306","name":"Missing Authentication for Critical Functionality"}],"description":"It was found that the Apache ActiveMQ client before 5.14.5 exposed a remote shutdown command in the ActiveMQConnection class. An attacker logged into a compromised broker could use this flaw to achieve denial of service on a connected client.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Improper Input Validation and Missing Authentication for Critical Function in Apache ActiveMQ","id":"CVE-2015-7559","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":"apache:activemq","products":["apache:activemq"],"type":"missing_authorization","year":"2015"},"n_packages":2,"n_references":2,"next":{"headline":"Missing authorization in n/a","id":"CVE-2015-7560"},"packages":[{"ecosystem":"Maven","fixed":["5.14.5"],"introduced":["0"],"last_affected":[],"package":"org.apache.activemq:activemq-client","purl":null,"source":"GHSA-jvpp-hxjj-5ccc"},{"ecosystem":"Maven","fixed":["5.14.5"],"introduced":["0"],"last_affected":[],"package":"org.apache.activemq:activemq-client","purl":"pkg:maven/org.apache.activemq/activemq-client","source":"GHSA-jvpp-hxjj-5ccc"}],"prev":{"headline":"librsvg DoS via Cyclic References","id":"CVE-2015-7558"},"products":["ActiveMQ"],"published":"2019-08-01","related":[{"cvss_score":10,"headline":"Apache ActiveMQ Deserialization of Untrusted Data","id":"CVE-2023-46604","kev_date_added":"2023-11-02","published":"2023-10-27"},{"cvss_score":9.8,"headline":"Apache ActiveMQ Improper Input Validation","id":"CVE-2016-3088","kev_date_added":"2022-02-10","published":"2016-06-01"},{"cvss_score":8.8,"headline":"Apache ActiveMQ Improper Input Validation","id":"CVE-2026-34197","kev_date_added":"2026-04-16","published":"2026-04-07"},{"cvss_score":9.8,"headline":"Remote code execution in Apache ActiveMQ","id":"CVE-2020-11998","kev_date_added":null,"published":"2020-09-10"},{"cvss_score":9.8,"headline":"Command Injection in Xstream","id":"CVE-2013-7285","kev_date_added":null,"published":"2019-05-15"},{"cvss_score":9.8,"headline":"Improper Restriction of XML External Entity Reference in Apache ActiveMQ","id":"CVE-2014-3600","kev_date_added":null,"published":"2017-10-27"},{"cvss_score":9.8,"headline":"Improper Input Validation in Apache ActiveMQ","id":"CVE-2015-5254","kev_date_added":null,"published":"2016-01-08"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["Apache"]},"summary":"An attacker with broker access can trigger a remote shutdown command, causing denial of service on connected ActiveMQ clients.","url":"https://insights.sbomify.com/CVE-2015-7559/"}