# CVE-2015-7559: Improper Input Validation and Missing Authentication for Critical Function in Apache ActiveMQ

> An attacker with broker access can trigger a remote shutdown command, causing denial of service on connected ActiveMQ clients.

- **Severity:** Low 2.7 (`CVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Aug 2019
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2015-7559, DLA-913-1, GHSA-jvpp-hxjj-5ccc, UBUNTU-CVE-2015-7559

## What is CVE-2015-7559?

CVE-2015-7559 is a low-severity missing authorization vulnerability in Apache Activemq, published on 1 Aug 2019. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

It was found that the Apache ActiveMQ client before 5.14.5 exposed a remote shutdown command in the ActiveMQConnection class. An attacker logged into a compromised broker could use this flaw to achieve denial of service on a connected client.

Weakness: CWE-20 (Improper Input Validation), CWE-306 (Missing Authentication for Critical Functionality)

## Which versions are affected by CVE-2015-7559?

2 open source packages ship an affected version, including org.apache.activemq:activemq-client. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.activemq:activemq-client` | Maven | All versions | 5.14.5 |
| `org.apache.activemq:activemq-client` | Maven | All versions | 5.14.5 |

Products: Apache Activemq, Redhat Jboss A-Mq, Redhat Jboss Fuse.

## How do I fix CVE-2015-7559?

Upgrade org.apache.activemq:activemq-client to 5.14.5 or later.

## Is CVE-2015-7559 being exploited?

There is no known exploitation of CVE-2015-7559 in the wild and no public exploit code.

## Other vulnerabilities in Apache Activemq

- [CVE-2023-46604](https://insights.sbomify.com/CVE-2023-46604/): Apache ActiveMQ Deserialization of Untrusted Data (critical 10.0, exploited in the wild)
- [CVE-2016-3088](https://insights.sbomify.com/CVE-2016-3088/): Apache ActiveMQ Improper Input Validation (critical 9.8, exploited in the wild)
- [CVE-2026-34197](https://insights.sbomify.com/CVE-2026-34197/): Apache ActiveMQ Improper Input Validation (high 8.8, exploited in the wild)
- [CVE-2020-11998](https://insights.sbomify.com/CVE-2020-11998/): Remote code execution in Apache ActiveMQ (critical 9.8)
- [CVE-2013-7285](https://insights.sbomify.com/CVE-2013-7285/): Command Injection in Xstream (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2015-7559 and fix it if it is affected.

What it is: CVE-2015-7559 is a low-severity missing authorization vulnerability in Apache Activemq, published on 1 Aug 2019. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2015-7559 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.activemq:activemq-client (Maven): affected all versions; fixed in 5.14.5
- org.apache.activemq:activemq-client (Maven): affected all versions; fixed in 5.14.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2015-7559/ (Markdown: https://insights.sbomify.com/CVE-2015-7559/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2015-7559
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2015-7559
- OSV: https://osv.dev/vulnerability/CVE-2015-7559

---
From sbomify Insights: https://insights.sbomify.com/CVE-2015-7559/
Summaries are generated and may contain mistakes; the official description above is the record.
