CVE-2015-7565 ember-source Cross-site Scripting vulnerability
Remote attackers can inject arbitrary web script or HTML via a cross-site scripting vulnerability in the Ember.js library.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2015-7565?
CVE-2015-7565 is a medium-severity cross-site scripting vulnerability in n/a, published on 13 Apr 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
Cross-site scripting (XSS) vulnerability in Ember.js 1.8.x through 1.10.x, 1.11.x before 1.11.4, 1.12.x before 1.12.2, 1.13.x before 1.13.12, 2.0.x before 2.0.3, 2.1.x before 2.1.2, and 2.2.x before 2.2.1 allows remote attackers to inject arbitrary web script or HTML.
Weakness: CWE-79
Which versions are affected by CVE-2015-7565?
12 open source packages ship an affected version, including ember-source. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
ember-source RubyGems | From 1.12.0 | 1.12.2 |
ember-source RubyGems | From 1.12.0 | 1.12.2 |
ember-source RubyGems | From 1.13.0 | 1.13.12 |
ember-source RubyGems | From 1.13.0 | 1.13.12 |
ember-source RubyGems | From 1.8.0 | 1.11.4 |
ember-source RubyGems | From 1.8.0 | 1.11.4 |
6 more packages
ember-source RubyGems | From 2.0.0 | 2.0.3 |
ember-source RubyGems | From 2.0.0 | 2.0.3 |
ember-source RubyGems | From 2.1.0 | 2.1.2 |
ember-source RubyGems | From 2.1.0 | 2.1.2 |
ember-source RubyGems | From 2.2.0 | 2.2.1 |
ember-source RubyGems | From 2.2.0 | 2.2.1 |
Products include Emberjs Ember.js.
How do I fix CVE-2015-7565?
Upgrade ember-source to a fixed version for your release line: 1.12.2, 1.13.12, 1.11.4 or 2.0.3.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2015-7565 being exploited?
There is no known exploitation of CVE-2015-7565 in the wild and no public exploit code.
Other vulnerabilities in n/a
- CVE-2013-4170 Ember.js Potential XSS Exploit When Binding `tagName` to User-Supplied Data
- CVE-2015-1866 ember-source vulnerable to Cross-site Scripting
- CVE-2014-0013 Ember.js Cross-site Scripting vulnerability
- CVE-2014-0014 ember-source Cross-site Scripting vulnerability
- CVE-2014-0046 ember-source Cross-site Scripting vulnerability
Sources
Also known as CLSA-2026-1780447820, GHSA-m3q7-rj8g-m457.