CVE-2015-7576 actionpack is vulnerable to remote bypass authentication
Remote attackers can bypass Basic Authentication in Ruby on Rails by exploiting timing differences in credential verification.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2015-7576?
CVE-2015-7576 is a low-severity vulnerability in Rubyonrails Rails, published on 16 Feb 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
The http_basic_authenticate_with method in actionpack/lib/action_controller/metal/http_authentication.rb in the Basic Authentication implementation in Action Controller in Ruby on Rails before 3.2.22.1, 4.0.x and 4.1.x before 4.1.14.1, 4.2.x before 4.2.5.1, and 5.x before 5.0.0.beta1.1 does not use a constant-time algorithm for verifying credentials, which makes it easier for remote attackers to bypass authentication by measuring timing differences.
Weakness: CWE-254
Which versions are affected by CVE-2015-7576?
4 open source packages ship an affected version, including actionpack. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
actionpack RubyGems | From 3.1.0 | 3.2.22.1 |
actionpack RubyGems | From 3.1.0 | 3.2.22.1 |
actionpack RubyGems | From 4.0.0 | 4.1.14.1 |
actionpack RubyGems | From 4.0.0 | 4.1.14.1 |
Linux distribution packages (10)
rubygem-activesupport-3_2 SUSE:Lifecycle Management Server 1.3 | All versions | 3.2.12-0.18.1 |
rubygem-activesupport-3_2 SUSE:Lifecycle Management Server 1.3 | All versions | 3.2.12-0.21.1 |
rubygem-activesupport-3_2 SUSE:Linux Enterprise Software Development Kit 11 SP3 | All versions | 3.2.12-0.18.1 |
rubygem-activesupport-3_2 SUSE:Linux Enterprise Software Development Kit 11 SP4 | All versions | 3.2.12-0.18.1 |
rubygem-activesupport-3_2 SUSE:Linux Enterprise Software Development Kit 11 SP4 | All versions | 3.2.12-0.21.1 |
rubygem-activesupport-4_1 SUSE:OpenStack Cloud 5 | All versions | 4.1.9-15.1 |
rubygem-activesupport-3_2 SUSE:Studio Onsite 1.3 | All versions | 3.2.12-0.18.1 |
rubygem-activesupport-3_2 SUSE:Studio Onsite 1.3 | All versions | 3.2.12-0.21.1 |
rubygem-activesupport-3_2 SUSE:WebYast 1.3 | All versions | 3.2.12-0.18.1 |
rubygem-activesupport-3_2 SUSE:WebYast 1.3 | All versions | 3.2.12-0.21.1 |
Products include Rubyonrails Rails, Rubyonrails Ruby on Rails.
How do I fix CVE-2015-7576?
Upgrade actionpack to a fixed version for your release line: 3.2.22.1 or 4.1.14.1.
Is CVE-2015-7576 being exploited?
There is no known exploitation of CVE-2015-7576 in the wild and no public exploit code.
Other vulnerabilities in Rubyonrails Rails
- CVE-2013-0277 Active Record contains deserialization of arbitrary YAML
- CVE-2017-17916 SQL injection in n/a
- CVE-2017-17917 SQL injection in n/a
- CVE-2026-33195 Rails Active Storage has possible Path Traversal in DiskService
- CVE-2024-26142 Rails possible ReDoS vulnerability in Accept header parsing in Action Dispatch
Sources
Also known as DEBIAN-CVE-2015-7576, GHSA-p692-7mm3-3fxg, SUSE-SU-2016:0623-1, SUSE-SU-2016:0857-1, SUSE-SU-2016:0968-1.