# CVE-2015-7576: actionpack is vulnerable to remote bypass authentication

> Remote attackers can bypass Basic Authentication in Ruby on Rails by exploiting timing differences in credential verification.

- **Severity:** Low 3.7 (`CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Feb 2016
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2015-7576, GHSA-p692-7mm3-3fxg, SUSE-SU-2016:0623-1, SUSE-SU-2016:0857-1, SUSE-SU-2016:0968-1

## What is CVE-2015-7576?

CVE-2015-7576 is a low-severity vulnerability in Rubyonrails Rails, published on 16 Feb 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The http_basic_authenticate_with method in actionpack/lib/action_controller/metal/http_authentication.rb in the Basic Authentication implementation in Action Controller in Ruby on Rails before 3.2.22.1, 4.0.x and 4.1.x before 4.1.14.1, 4.2.x before 4.2.5.1, and 5.x before 5.0.0.beta1.1 does not use a constant-time algorithm for verifying credentials, which makes it easier for remote attackers to bypass authentication by measuring timing differences.

Weakness: CWE-254

## Which versions are affected by CVE-2015-7576?

4 open source packages ship an affected version, including actionpack. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `actionpack` | RubyGems | From 3.1.0 | 3.2.22.1 |
| `actionpack` | RubyGems | From 3.1.0 | 3.2.22.1 |
| `actionpack` | RubyGems | From 4.0.0 | 4.1.14.1 |
| `actionpack` | RubyGems | From 4.0.0 | 4.1.14.1 |
| `rubygem-activesupport-3_2` | SUSE:Lifecycle Management Server 1.3 | All versions | 3.2.12-0.18.1 |
| `rubygem-activesupport-3_2` | SUSE:Lifecycle Management Server 1.3 | All versions | 3.2.12-0.21.1 |
| `rubygem-activesupport-3_2` | SUSE:Linux Enterprise Software Development Kit 11 SP3 | All versions | 3.2.12-0.18.1 |
| `rubygem-activesupport-3_2` | SUSE:Linux Enterprise Software Development Kit 11 SP4 | All versions | 3.2.12-0.18.1 |
| `rubygem-activesupport-3_2` | SUSE:Linux Enterprise Software Development Kit 11 SP4 | All versions | 3.2.12-0.21.1 |
| `rubygem-activesupport-4_1` | SUSE:OpenStack Cloud 5 | All versions | 4.1.9-15.1 |
| `rubygem-activesupport-3_2` | SUSE:Studio Onsite 1.3 | All versions | 3.2.12-0.18.1 |
| `rubygem-activesupport-3_2` | SUSE:Studio Onsite 1.3 | All versions | 3.2.12-0.21.1 |
| `rubygem-activesupport-3_2` | SUSE:WebYast 1.3 | All versions | 3.2.12-0.18.1 |
| `rubygem-activesupport-3_2` | SUSE:WebYast 1.3 | All versions | 3.2.12-0.21.1 |

Products: Rubyonrails Rails, Rubyonrails Ruby on Rails.

## How do I fix CVE-2015-7576?

Upgrade actionpack to a fixed version for your release line: 3.2.22.1 or 4.1.14.1.

## Is CVE-2015-7576 being exploited?

There is no known exploitation of CVE-2015-7576 in the wild and no public exploit code.

## Other vulnerabilities in Rubyonrails Rails

- [CVE-2013-0277](https://insights.sbomify.com/CVE-2013-0277/): Active Record contains deserialization of arbitrary YAML (critical 10.0)
- [CVE-2017-17916](https://insights.sbomify.com/CVE-2017-17916/): SQL injection in n/a (high 8.1)
- [CVE-2017-17917](https://insights.sbomify.com/CVE-2017-17917/): SQL injection in n/a (high 8.1)
- [CVE-2026-33195](https://insights.sbomify.com/CVE-2026-33195/): Rails Active Storage has possible Path Traversal in DiskService (high 8.0)
- [CVE-2024-26142](https://insights.sbomify.com/CVE-2024-26142/): Rails possible ReDoS vulnerability in Accept header parsing in Action Dispatch (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2015-7576 and fix it if it is affected.

What it is: CVE-2015-7576 is a low-severity vulnerability in Rubyonrails Rails, published on 16 Feb 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2015-7576 in the wild and no public exploit code.

Affected packages and fixed versions:
- actionpack (RubyGems): affected from 3.1.0; fixed in 3.2.22.1
- actionpack (RubyGems): affected from 3.1.0; fixed in 3.2.22.1
- actionpack (RubyGems): affected from 4.0.0; fixed in 4.1.14.1
- actionpack (RubyGems): affected from 4.0.0; fixed in 4.1.14.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2015-7576/ (Markdown: https://insights.sbomify.com/CVE-2015-7576/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2015-7576
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2015-7576
- OSV: https://osv.dev/vulnerability/CVE-2015-7576

---
From sbomify Insights: https://insights.sbomify.com/CVE-2015-7576/
Summaries are generated and may contain mistakes; the official description above is the record.
