# CVE-2015-7577: Active Record Improper Access Control

> Attackers can bypass intended change restrictions in nested attributes due to improper destroy option implementation in Active Record.

- **Severity:** Medium 5.3 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Feb 2016
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2015-7577, DLA-496-1, GHSA-xrr6-3pc4-m447, SUSE-SU-2016:0619-1

## What is CVE-2015-7577?

CVE-2015-7577 is a medium-severity vulnerability in Rubyonrails Rails, published on 16 Feb 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

activerecord/lib/active_record/nested_attributes.rb in Active Record in Ruby on Rails 3.1.x and 3.2.x before 3.2.22.1, 4.0.x and 4.1.x before 4.1.14.1, 4.2.x before 4.2.5.1, and 5.x before 5.0.0.beta1.1 does not properly implement a certain destroy option, which allows remote attackers to bypass intended change restrictions by leveraging use of the nested attributes feature.

Weakness: CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2015-7577?

8 open source packages ship an affected version, including activerecord. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `activerecord` | RubyGems | From 3.1.0 | 3.2.22.1 |
| `activerecord` | RubyGems | From 3.1.0 | 3.2.22.1 |
| `activerecord` | RubyGems | From 4.0.0 | 4.1.14.1 |
| `activerecord` | RubyGems | From 4.0.0 | 4.1.14.1 |
| `activerecord` | RubyGems | From 4.2.0 | 4.2.5.1 |
| `activerecord` | RubyGems | From 4.2.0 | 4.2.5.1 |
| `activerecord` | RubyGems | From 5.0.0.beta1 | 5.0.0.beta1.1 |
| `activerecord` | RubyGems | From 5.0.0.beta1 | 5.0.0.beta1.1 |
| `rubygem-activerecord-3_2` | SUSE:Lifecycle Management Server 1.3 | All versions | 3.2.12-0.15.1 |
| `rubygem-activerecord-3_2` | SUSE:Linux Enterprise Software Development Kit 11 SP4 | All versions | 3.2.12-0.15.1 |
| `rubygem-activerecord-3_2` | SUSE:Studio Onsite 1.3 | All versions | 3.2.12-0.15.1 |
| `rubygem-activerecord-3_2` | SUSE:WebYast 1.3 | All versions | 3.2.12-0.15.1 |

Products: Rubyonrails Rails, Rubyonrails Ruby on Rails.

## How do I fix CVE-2015-7577?

Upgrade activerecord to a fixed version for your release line: 3.2.22.1, 4.1.14.1, 4.2.5.1 or 5.0.0.beta1.1.

## Is CVE-2015-7577 being exploited?

There is no known exploitation of CVE-2015-7577 in the wild and no public exploit code.

## Other vulnerabilities in Rubyonrails Rails

- [CVE-2013-0277](https://insights.sbomify.com/CVE-2013-0277/): Active Record contains deserialization of arbitrary YAML (critical 10.0)
- [CVE-2017-17916](https://insights.sbomify.com/CVE-2017-17916/): SQL injection in n/a (high 8.1)
- [CVE-2017-17917](https://insights.sbomify.com/CVE-2017-17917/): SQL injection in n/a (high 8.1)
- [CVE-2026-33195](https://insights.sbomify.com/CVE-2026-33195/): Rails Active Storage has possible Path Traversal in DiskService (high 8.0)
- [CVE-2024-26142](https://insights.sbomify.com/CVE-2024-26142/): Rails possible ReDoS vulnerability in Accept header parsing in Action Dispatch (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2015-7577 and fix it if it is affected.

What it is: CVE-2015-7577 is a medium-severity vulnerability in Rubyonrails Rails, published on 16 Feb 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2015-7577 in the wild and no public exploit code.

Affected packages and fixed versions:
- activerecord (RubyGems): affected from 3.1.0; fixed in 3.2.22.1
- activerecord (RubyGems): affected from 3.1.0; fixed in 3.2.22.1
- activerecord (RubyGems): affected from 4.0.0; fixed in 4.1.14.1
- activerecord (RubyGems): affected from 4.0.0; fixed in 4.1.14.1
- activerecord (RubyGems): affected from 4.2.0; fixed in 4.2.5.1
- activerecord (RubyGems): affected from 4.2.0; fixed in 4.2.5.1
- activerecord (RubyGems): affected from 5.0.0.beta1; fixed in 5.0.0.beta1.1
- activerecord (RubyGems): affected from 5.0.0.beta1; fixed in 5.0.0.beta1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2015-7577/ (Markdown: https://insights.sbomify.com/CVE-2015-7577/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2015-7577
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2015-7577
- OSV: https://osv.dev/vulnerability/CVE-2015-7577

---
From sbomify Insights: https://insights.sbomify.com/CVE-2015-7577/
Summaries are generated and may contain mistakes; the official description above is the record.
