# CVE-2015-7579: rails-html-sanitizer Cross-site Scripting vulnerability

> Remote attackers can inject arbitrary web script or HTML via mishandled HTML entities in the rails-html-sanitizer gem.

- **Severity:** Medium 6.1 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 16 Feb 2016
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2015-7579, GHSA-r9c2-cr39-c8g6

## What is CVE-2015-7579?

CVE-2015-7579 is a medium-severity cross-site scripting vulnerability in n/a, published on 16 Feb 2016. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Cross-site scripting (XSS) vulnerability in the rails-html-sanitizer gem 1.0.2 for Ruby on Rails 4.2.x and 5.x allows remote attackers to inject arbitrary web script or HTML via an HTML entity that is mishandled by the Rails::Html::FullSanitizer class.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2015-7579?

2 open source packages ship an affected version, including rails-html-sanitizer. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `rails-html-sanitizer` | RubyGems | All versions | 1.0.3 |
| `rails-html-sanitizer` | RubyGems | All versions | 1.0.3 |

Products: Rubyonrails Html Sanitizer.

## How do I fix CVE-2015-7579?

Upgrade rails-html-sanitizer to 1.0.3 or later.

## Is CVE-2015-7579 being exploited?

There is no known exploitation of CVE-2015-7579 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2018-3741](https://insights.sbomify.com/CVE-2018-3741/): rails-html-sanitizer Cross-site Scripting vulnerability (medium 6.1)
- [CVE-2015-7578](https://insights.sbomify.com/CVE-2015-7578/): rails-html-sanitizer Cross-site Scripting vulnerability (medium 6.1)
- [CVE-2015-7580](https://insights.sbomify.com/CVE-2015-7580/): rails-html-sanitizer Cross-site Scripting vulnerability (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2015-7579 and fix it if it is affected.

What it is: CVE-2015-7579 is a medium-severity cross-site scripting vulnerability in n/a, published on 16 Feb 2016. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2015-7579 in the wild and no public exploit code.

Affected packages and fixed versions:
- rails-html-sanitizer (RubyGems): affected all versions; fixed in 1.0.3
- rails-html-sanitizer (RubyGems): affected all versions; fixed in 1.0.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2015-7579/ (Markdown: https://insights.sbomify.com/CVE-2015-7579/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2015-7579
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2015-7579
- OSV: https://osv.dev/vulnerability/CVE-2015-7579

---
From sbomify Insights: https://insights.sbomify.com/CVE-2015-7579/
Summaries are generated and may contain mistakes; the official description above is the record.
