{"answers":{"affected":"2 open source packages ship an affected version, including rails-html-sanitizer. It affects 1 product.","exploited":"There is no known exploitation of CVE-2015-7580 in the wild and no public exploit code.","fix":"Upgrade rails-html-sanitizer to 1.0.3 or later.","what":"CVE-2015-7580 is a medium-severity cross-site scripting vulnerability in n/a, published on 16 Feb 2016. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2015-7580 and fix it if it is affected.\n\nWhat it is: CVE-2015-7580 is a medium-severity cross-site scripting vulnerability in n/a, published on 16 Feb 2016. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2015-7580 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- rails-html-sanitizer (RubyGems): affected all versions; fixed in 1.0.3\n- rails-html-sanitizer (RubyGems): affected all versions; fixed in 1.0.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2015-7580/ (Markdown: https://insights.sbomify.com/CVE-2015-7580/index.md)","id":"CVE-2015-7580","markdown":"https://insights.sbomify.com/CVE-2015-7580/index.md","name":"CVE-2015-7580","record":{"aliases":["DEBIAN-CVE-2015-7580","GHSA-ghqm-pgxj-37gq"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Ruby HTML sanitizer","requires_auth":"none","summary":"Remote attackers can inject arbitrary web script or HTML via crafted CDATA nodes in the rails-html-sanitizer gem.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"html_sanitizer","vendor":"rubyonrails"}],"cvss":{"score":6.1,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Cross-site scripting (XSS) vulnerability in lib/rails/html/scrubbers.rb in the rails-html-sanitizer gem before 1.0.3 for Ruby on Rails 4.2.x and 5.x allows remote attackers to inject arbitrary web script or HTML via a crafted CDATA node.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"rails-html-sanitizer Cross-site Scripting vulnerability","id":"CVE-2015-7580","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"xss","year":"2015"},"n_packages":2,"n_references":7,"next":{"headline":"actionpack is vulnerable to denial of service because of a wildcard controller route","id":"CVE-2015-7581"},"packages":[{"ecosystem":"RubyGems","fixed":["1.0.3"],"introduced":["0"],"last_affected":[],"package":"rails-html-sanitizer","purl":null,"source":"GHSA-ghqm-pgxj-37gq"},{"ecosystem":"RubyGems","fixed":["1.0.3"],"introduced":["0"],"last_affected":[],"package":"rails-html-sanitizer","purl":"pkg:gem/rails-html-sanitizer","source":"GHSA-ghqm-pgxj-37gq"}],"prev":{"headline":"rails-html-sanitizer Cross-site Scripting vulnerability","id":"CVE-2015-7579"},"products":["n/a"],"published":"2016-02-16","related":[{"cvss_score":6.1,"headline":"rails-html-sanitizer Cross-site Scripting vulnerability","id":"CVE-2018-3741","kev_date_added":null,"published":"2018-03-30"},{"cvss_score":6.1,"headline":"rails-html-sanitizer Cross-site Scripting vulnerability","id":"CVE-2015-7578","kev_date_added":null,"published":"2016-02-16"},{"cvss_score":6.1,"headline":"rails-html-sanitizer Cross-site Scripting vulnerability","id":"CVE-2015-7579","kev_date_added":null,"published":"2016-02-16"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote attackers can inject arbitrary web script or HTML via crafted CDATA nodes in the rails-html-sanitizer gem.","url":"https://insights.sbomify.com/CVE-2015-7580/"}