# CVE-2015-7581: actionpack is vulnerable to denial of service because of a wildcard controller route

> Remote attackers can cause denial of service via excessive memory consumption in Ruby on Rails applications using wildcard controller routes.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Feb 2016
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2015-7581, GHSA-9h6g-gp95-x3q5

## What is CVE-2015-7581?

CVE-2015-7581 is a high-severity denial of service vulnerability in Rubyonrails Rails, published on 16 Feb 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

actionpack/lib/action_dispatch/routing/route_set.rb in Action Pack in Ruby on Rails 4.x before 4.2.5.1 and 5.x before 5.0.0.beta1.1 allows remote attackers to cause a denial of service (superfluous caching and memory consumption) by leveraging an application's use of a wildcard controller route.

Weakness: CWE-399

## Which versions are affected by CVE-2015-7581?

2 open source packages ship an affected version, including actionpack. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `actionpack` | RubyGems | From 4.0.0 | 4.2.5.1 |
| `actionpack` | RubyGems | From 4.0.0 | 4.2.5.1 |

Products: Rubyonrails Rails.

## How do I fix CVE-2015-7581?

Upgrade actionpack to 4.2.5.1 or later.

## Is CVE-2015-7581 being exploited?

There is no known exploitation of CVE-2015-7581 in the wild and no public exploit code.

## Other vulnerabilities in Rubyonrails Rails

- [CVE-2013-0277](https://insights.sbomify.com/CVE-2013-0277/): Active Record contains deserialization of arbitrary YAML (critical 10.0)
- [CVE-2017-17916](https://insights.sbomify.com/CVE-2017-17916/): SQL injection in n/a (high 8.1)
- [CVE-2017-17917](https://insights.sbomify.com/CVE-2017-17917/): SQL injection in n/a (high 8.1)
- [CVE-2026-33195](https://insights.sbomify.com/CVE-2026-33195/): Rails Active Storage has possible Path Traversal in DiskService (high 8.0)
- [CVE-2024-26142](https://insights.sbomify.com/CVE-2024-26142/): Rails possible ReDoS vulnerability in Accept header parsing in Action Dispatch (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2015-7581 and fix it if it is affected.

What it is: CVE-2015-7581 is a high-severity denial of service vulnerability in Rubyonrails Rails, published on 16 Feb 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2015-7581 in the wild and no public exploit code.

Affected packages and fixed versions:
- actionpack (RubyGems): affected from 4.0.0; fixed in 4.2.5.1
- actionpack (RubyGems): affected from 4.0.0; fixed in 4.2.5.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2015-7581/ (Markdown: https://insights.sbomify.com/CVE-2015-7581/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2015-7581
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2015-7581
- OSV: https://osv.dev/vulnerability/CVE-2015-7581

---
From sbomify Insights: https://insights.sbomify.com/CVE-2015-7581/
Summaries are generated and may contain mistakes; the official description above is the record.
